Download Action "open" with firefox + Force new window spawn to open in a new tab creates infinite tabs/windows

RESOLVED DUPLICATE of bug 218257

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 218257
12 years ago
10 years ago

People

(Reporter: David Buchman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If the Download Action for a given type is set to "open" with firefox (firefox.exe), and the option under the "Tabs" section in the Firefox Preferences for "Force links that open new windows to open in:" is set to "a new tab", and then say, click a link whose extension/type matches that of the defined Download Action, then firefox simply "does nothing," in that it "thinks" for a fraction of a second, but navigation never changes, nor does the uri/content. However, if you "right-click on that link and select "Open Link in New Tab", firefox begins spawning infinite tabs (in the present window), this process continues endlessly - this infinite spawning of tabs can apparently be broken by attempting to close the newest tabs firefox has opened or is about to open apparently halts this process of spawning infinite tabs (on my fast system, the rate at which it spawns them is so fast that keeping-up, so to speak, would be impossible so when I clicked the 'X' on the "tab bar", it processed the input and then spawned about 10 more tabs or more and then halted spawning new tabs).
More critically, apparently, I after having to killall firefox processes and loosing my first attempt at a bugreport (my fault for "testing hunches" while writing my critical bug, in firefox ;), I decided to investigate a little further myself. I discovered something even more horrible. With the same settings as described above, if I _instead_, right-click on that link and select "Open Link in New Window", firefox begins spawning _infinite windows_! - and each new window it spawns in this never-ending process begins spawning infinite tabs, within each of these windows, endlessly! (fortunately I was able to killall the firefox processes, as mentioned above, before my system completely hung-up or used up all its memory). *NOTE* Unlike the "infinite tabs" issue, which I mentioned first, this latter issue, however, could NOT be halted, once set in motion (I rapidly attempted to close every window it spawned, however, even closing the all the new ones it was spawning (including all the tabs it began internally spawning, included), and the original ("parent"), window that started this whole mess, it kept opening new windows. Ergo, the total process termination was required.

The example I used, repeatedly (since that's how I initially ran into it), was to use the Download Action for ".png image/png" as the mime-type.

Reproducible: Always

Steps to Reproduce:
Set Tabs option "Force links that open new windows to open in" to "a new tab".
Set Download Action for ".png image/png" to open with Firefox.
Browse to a webpage that contains a hyperlink to a resource matching the aforementioned resource type (e.g. PNG).
Right-click on the above stated hyperlink and select either "Open Link in New Tab" or "Open Link in Window".
Actual Results:  
If "Open Link in New Tab" was selected, Firefox begins infinitely spawning new tabs in the current browser window (see Note in Additional Information for this bug).
If "Open Link in New Window" was selected, Firefox begins infinitely spawning new windows, each new window that is spawned in this manner, itself, begins infinitely spawning new tabs within it.

As stated in the bug details, while the infinite tabs spawning [in the current window] is apparently "haltable", the infinite windows/(+tabs) is not, and appears to halt/bring-down the system rather quickly! Therefore, if this is in fact a bug (or issue that has gone uncheck or not since been reported/resolved),  I would deem it severe or critical.

Expected Results:  
Open predefined resource type in firefox, as appropriately specified in the firefox configuration, accordingly.

Under the "Tabs" preferences in firefox, I have the "Open links from other applications in:" option set to "a new tab in the most recent window".
I have no idea whether or not this is at all relevant/pertinent, however I thought I should simply mention it - it is my presumption that it has no bearing on the current issue at hand.

The bug appears to be reproducible for me.
Note, I have not attempted it on any other systems (physical or software).
Trying to figure out how to effectively block users from selecting firefox.exe is the reason this isn't fixed, fortunately few people try this.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 218257 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.