Last Comment Bug 328441 - Observer service does not specify threading behaviour
: Observer service does not specify threading behaviour
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Doug Turner (:dougt)
:
: Nathan Froyd [:froydnj]
Mentors:
http://lxr.mozilla.org/mozilla/source...
Depends on: 326491
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 03:49 PST by :Mook
Modified: 2006-03-04 06:29 PST (History)
3 users (show)
bzbarsky: blocking1.9a1+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description :Mook 2006-02-24 03:49:49 PST
(See URL)

I'm going to be having a secondary thread calling nsIObserverService::notifyObservers().  nsIObserverService does not define which thread the registered observers will be notified on (at least, according to the IDL).

It would be very useful to have this actually specified.  Currently guessing this will be whichever thread the notify was on, but please actually say that in the IDL because I'm probably wrong :p
Comment 1 Christian :Biesinger (don't email me, ping me on IRC) 2006-03-04 06:29:17 PST
fixed by bug 326491, nsXPCOMCID.h now says:
 * Observer Service ContractID
 * The observer service implements the global nsIObserverService object.
 * It should be used from the main thread only.
 */
#define NS_OBSERVERSERVICE_CONTRACTID "@mozilla.org/observer-service;1"

Note You need to log in before you can comment on or make changes to this bug.