Closed Bug 328492 Opened 14 years ago Closed 14 years ago

Set dom.disable_window_move_resize to true by default

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Gavin, Unassigned)

References

(Depends on 1 open bug)

Details

Flags: blocking-firefox2?
Depends on: 186708
So if either/both of the dependencies are fixed, do we gain a benefit from switching this by default?
The double negation is confusing.

Resizing and moving was initially disabled (setting dom.disable_window_move_resize to true) in bug 299424, then re-enabled in bug 309251 since disabling it by default broke too many legitimate uses. By fixing bug 144069 and 186708, we're making it harder for sites to abuse the moving/resizing, so I don't understand how it follows that once they are fixed we should revert to disallowing it by default. Therefore, I think this is WONTFIX, or INVALID.

Am I misunderstanding anything?
Agreed!
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: blocking-firefox2?
Resolution: --- → WONTFIX
Jesse's original rationale for the default to be disallowed was:

----
Should be disallowed by default, except in windows opened by JavaScript with
only one tab.  It is frequently used to annoy visitors, and I don't think many
web applications need it.  (Bug 144069, bug 186708, bug 60323, bug 262660.)
----

Fixing the deps would mean that if a user was browsing w/o toolbars in their main browser window, that window could still be resized. It's not an incredibly common case, I admit, but it would annoy the heck out of anyone running in kiosk mode, I'd wager (unless that doesn't allow resizes, either)

I guess I just don't see the rationale for allowing these attributes on a primary browser window. I'm not especially passionate about it, though, so I'll take a WONTFIX with a smile.
*** Bug 332630 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 375100
Duplicate of this bug: 441512
Duplicate of this bug: 533423
You need to log in before you can comment on or make changes to this bug.