All users were logged out of Bugzilla on October 13th, 2018

Error parsing ics file with X-MOZ-LASTACK element due typo

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: RuCla, Assigned: ssitter)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If I try to use an external ics file which includes a repeat option "e.g. second monday in may" Sunbird gives the attached error message at the start

Reproducible: Always
(Reporter)

Comment 1

13 years ago
Created attachment 213069 [details]
Error picture

Comment 2

13 years ago
For future reference, you can just cut and paste the 'details' part of the error message.  Can you please attach the ics file that you're seeing this with?  (Just the single VEVENT-block is fine.)
(Reporter)

Comment 3

13 years ago
Created attachment 213071 [details]
External ics file leeds to an error

Comment 4

13 years ago
The attached event is not a problem.  I opened it without difficulty in Sunbird.  Rather, there seems to be another event with an alarm that you dismissed that is causing things to go wrong.  Look through the ics file in question for other events that contain an X-MOZ-LASTACK property.  Eliminating those ought to pin down what the problem is.
(Reporter)

Comment 5

13 years ago
If I remove the attached entry, I don't get any error messages
(Reporter)

Comment 6

13 years ago
I have tested it again: I only insert the following line and the same error message occurs:

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
(Assignee)

Comment 7

13 years ago
Confirmed.

After making a valid calendar file out of the attached event and trying to import it I get the same error as seen by reporter. (In 2006-02-23 build it works ok.)

After removing the line: 
  X-MOZ-LASTACK:20060224T171441Z
from ics file I can import the event in 2006-02-24 build successfully.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 8

13 years ago
Created attachment 213091 [details] [diff] [review]
fix typo
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #213091 - Flags: first-review?(jminta)
(Assignee)

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All
Summary: External ics file leeds to an error → Error parsing ics file with X-MOZ-LASTACK element due typo
Version: unspecified → Trunk

Comment 9

13 years ago
Comment on attachment 213091 [details] [diff] [review]
fix typo

Sweet! r=jminta

Just to clarify why I thought this was WFM:  When solaria went red after the original landing last night, the fix ended up making this type of error much more fatal.  I hacked that fix in a separate tree and as such, the error was silent, rather than fatal.
Attachment #213091 - Flags: first-review?(jminta) → first-review+

Comment 10

13 years ago
Patch checked in.  Please verify in tomorrow's nightly.  (Please also check the multiweek-bug, as it may be related.)
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

13 years ago
I have checked the bug: 
The error do not occurs anymore but the date is deleted in the ics file.
The multiweek bug is still in Sunbird: It is not possible to create a new task or event
Status: RESOLVED → VERIFIED
(Assignee)

Comment 12

13 years ago
(In reply to comment #11)
> I have checked the bug: 
> The error do not occurs anymore but the date is deleted in the ics file.

What do you mean with that? This sounds even worse. An event without date? What did you did to get this results?
(Reporter)

Comment 13

13 years ago
The error occurs when a date is created which includes repeat option like this:
second monday in may.
Now the concerning date was deleted. after I copied it again in the ics file it is in the file but it isn't shown in Sunbird.
(Reporter)

Comment 14

13 years ago
Very strange: after restarting SB the event is now here. 
(Reporter)

Comment 15

13 years ago
I found the following tags in the ics file:
DTSTART;VALUE=DATE;TZID=/mozilla.org/20050126_1/Africa/Ceuta:20040214
DTEND;VALUE=DATE;TZID=/mozilla.org/20050126_1/Africa/Ceuta:20040215

Is this the reason that the concerning date is not shown in the calendar?
(Reporter)

Comment 16

13 years ago
When I modify the entry like this the entry is shown in the calendar:
DTSTART;VALUE=DATE:20040214
DTEND;VALUE=DATE:20040215
You need to log in before you can comment on or make changes to this bug.