Closed Bug 328505 Opened 15 years ago Closed 15 years ago

--install-app fails on Linux for packages without a vendor

Categories

(Toolkit Graveyard :: XULRunner, defect)

1.8 Branch
All
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.8.1

People

(Reporter: rdmsoft, Assigned: rdmsoft)

Details

(Keywords: fixed1.8.0.2, fixed1.8.1, Whiteboard: [nvn-dl])

Attachments

(1 file)

The Windows and Mac code in nsXULAppInstall.js checks for vendor before using it, the Linux code doesn't.
Attached patch fixSplinter Review
Assignee: nobody → rdmsoft
Status: NEW → ASSIGNED
Attachment #213070 - Flags: first-review?(benjamin)
Attachment #213070 - Flags: first-review?(benjamin)
Attachment #213070 - Flags: first-review+
Attachment #213070 - Flags: approval-branch-1.8.1+
Landed on the 1.8 branch and trunk.
mozilla/xulrunner/setup/nsXULAppInstall.js 	1.2.2.4
mozilla/xulrunner/setup/nsXULAppInstall.js 	1.4
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8.1
Version: unspecified → 1.8 Branch
Comment on attachment 213070 [details] [diff] [review]
fix

I think this should go into 1.8.0.2.
Small fix to XULRunner on Linux, doesn't affect Firefox or Thunderbird.
Attachment #213070 - Flags: approval1.8.0.2?
Comment on attachment 213070 [details] [diff] [review]
fix

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #213070 - Flags: approval1.8.0.2? → approval1.8.0.2+
mozilla/xulrunner/setup/nsXULAppInstall.js; new revision: 1.2.2.3.2.1;
Keywords: fixed1.8.0.2
Whiteboard: [nvn-dl]
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.