<td> border attribute unrecognised if <table border=0>

VERIFIED DUPLICATE of bug 25228

Status

()

defect
P3
major
VERIFIED DUPLICATE of bug 25228
19 years ago
19 years ago

People

(Reporter: bora123, Assigned: karnaze)

Tracking

({testcase})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

19 years ago
I compared the CSS2 implementation in Mozilla M14 and IE 5.01, on IE everything
works with all the objects. For example, 

border-width:2px; border-style:solid; border-right-color:000000; border-left-
color:#ffffff; border-top-color:#ffffff;border-bottom-color:#000000


The CSS2 styles given upthere applies to all the objects from <TD> to <B>. Even 
for <B> object, IE 5.01 draws a border successfully. On Mozilla, none of these
are implemented for all objects except 'Form' objects. Is this a bug? if it is 
not a bug, then will Mozilla ever have a complete CSS support? On the other 
hand, I cant set the size of the font size using 'font-size'?
Could you give a test case showing a bug?  Without that, I think this bug is
INVALID, since the things you describe are known to work.
Target Milestone: ---

Comment 2

19 years ago
Oh come on... CSS2 is WAY spotty...
Overflow:hidden is busted, etc etc etc
But CSS2 is "unsupported" which will make DHTML very sucky in Moz.
CSS2 implementation NEEDS to get fleshed out.

Please file *specific* bugs on things that don't work right or features that you
think should be implemented.  Mozilla supports a lot more of CSS2 than IE5 or
NN4 does.  It just happens that some of the positioning and visual effects parts
aren't completely in yet because either:
 * they're still being worked out in the working group
 * the bugs just haven't been fixed yet.
Is this a bug on static CSS styles or CSS access through the DOM, either way if
I don't get a specific explanation (ie a testcase) there's not much I can do,
this will be marked invalid unless someone can say exactly what's wrong.
Reporter

Comment 5

19 years ago
<table cellspacing=0 cellpadding=0>
<tr>
<td style="border-width:2px; border-style:solid; border-right-color:000000; 
border-left-color:#ffffff; border-top-color:#ffffff;border-bottom-color:#000000"
> Border </td></tr>

The above code should draw a border around that particular cell. Mozilla is not 
drawing it. However, it works well on <table> itself. I didnt check CSS changes
thru DOM. I will do so tonight.
Well, I just tested this in both IE 5 and with todays mozilla, both display the
above sample exactly the same, to the pixel AFAIK. What version of mozilla are
you testsing with?
Reporter

Comment 7

19 years ago
very interesting, it really works. But I figured out the problem I got,
if I give the border of table as '0'. Then it is not showing up. Try this;

<table cellspacing=0 cellpadding=0 border=0> 
<tr> 
<td style="border-width:1px; border-style:solid; border-right-color:000000; 
border-left-color:#ffffff; border-top-color:#ffffff;border-bottom-
color:#000000" > 
Border </td>
</tr> 
</table>
Nothing DOM about this any more, over to HTML Tables...
Assignee: jst → karnaze
Component: DOM Level 2 → HTMLTables
OS: other → All
QA Contact: vidur → chrisd
Rewriting title, adding testcase keyword (though I can't verify if the testcase 
is correct, as I don't have IE 5).

Gerv
Keywords: testcase
Summary: CSS 2 is severly incomplete → <td> border attribute unrecognised if <table border=0>
Assignee

Comment 11

19 years ago

*** This bug has been marked as a duplicate of 25228 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 12

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.