Last Comment Bug 328769 - assertion running e4x tests
: assertion running e4x tests
Status: VERIFIED FIXED
[patch][rft-dl]
: assertion, verified1.8.0.2, verified1.8.1
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla1.9alpha1
Assigned To: Blake Kaplan (:mrbkap) (please use needinfo!)
:
Mentors:
Depends on:
Blocks: 328249
  Show dependency treegraph
 
Reported: 2006-02-27 12:31 PST by Blake Kaplan (:mrbkap) (please use needinfo!)
Modified: 2006-11-10 12:22 PST (History)
4 users (show)
bob: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (2.20 KB, patch)
2006-02-27 12:32 PST, Blake Kaplan (:mrbkap) (please use needinfo!)
mrbkap: review+
brendan: approval‑branch‑1.8.1+
dveditz: approval1.8.0.2+
Details | Diff | Review

Description Blake Kaplan (:mrbkap) (please use needinfo!) 2006-02-27 12:31:07 PST
bug 328249 added an assertion that we never see lists of length > 1 in CheckCycle, but this isn't the case, thanks to Insert. Instead of trying to handle lists in CheckCycle, we should simply only pass elements to it, and do the looping (and flattening) elsewhere.
Comment 1 Blake Kaplan (:mrbkap) (please use needinfo!) 2006-02-27 12:32:31 PST
Created attachment 213361 [details] [diff] [review]
Fix

This has r=brendan
Comment 2 Blake Kaplan (:mrbkap) (please use needinfo!) 2006-02-27 12:34:13 PST
Fix checked into trunk.
Comment 3 Blake Kaplan (:mrbkap) (please use needinfo!) 2006-02-27 12:36:15 PST
Comment on attachment 213361 [details] [diff] [review]
Fix

Since bug 328249 was checked into the branch, we need this too.
Comment 4 Brendan Eich [:brendan] 2006-02-27 13:09:51 PST
Comment on attachment 213361 [details] [diff] [review]
Fix

This is a followup fix to the 1.8.0 branch, safe for 1.8.0.2 if that's still taking fixes.

/be
Comment 5 Daniel Veditz [:dveditz] 2006-02-27 18:33:33 PST
Comment on attachment 213361 [details] [diff] [review]
Fix

approved for 1.8.0 branch, a=dveditz
Comment 6 Blake Kaplan (:mrbkap) (please use needinfo!) 2006-02-27 18:40:10 PST
Fix checked into the 1.8 branches.
Comment 7 Dave Liebreich [:davel] 2006-03-02 13:50:30 PST
please provide testcase or test guidance for this fix.
Comment 8 Blake Kaplan (:mrbkap) (please use needinfo!) 2006-03-02 13:52:15 PST
The testcase in js/tests/e4x/Expressions/11.6.1.js covers this.
Comment 9 Bob Clary [:bc:] 2006-03-02 13:55:25 PST
practically every test failed with this bug. I did not see any crashes in my nightly build testing and am running debug build testing now. I will verify it when I complete.
Comment 10 Bob Clary [:bc:] 2006-03-07 15:20:23 PST
no longer see the failures which resulted from this bug.

Note You need to log in before you can comment on or make changes to this bug.