Last Comment Bug 328845 - An universal build with --enable-chrome-format=flat fails with an error
: An universal build with --enable-chrome-format=flat fails with an error
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 07:30 PST by Pu7o
Modified: 2006-02-28 08:16 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Pu7o 2006-02-28 07:30:17 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/420+ Trunk/20060227 (KHTML, like Gecko) Safari/417.8
Build Identifier: 

An universal build with --enable-chrome-format=flat fails with an error.

Reproducible: Always

Steps to Reproduce:
1.Try to compile a mozilla product with a flat chrome using the universal build system on Mac OS X

Actual Results:  
rm -f /Users/puto/sources/firescape/mozilla/../build/ppc/dist/firefox/DeerPark.app/Contents/MacOS/*.chk \
      /Users/puto/sources/firescape/mozilla/../build/i386/dist/firefox/DeerPark.app/Contents/MacOS/*.chk
/Users/puto/sources/firescape/mozilla/build/macosx/universal/fix-buildconfig \
  /Users/puto/sources/firescape/mozilla/../build/ppc/dist/firefox/DeerPark.app/Contents/MacOS/chrome/toolkit.jar \
  /Users/puto/sources/firescape/mozilla/../build/i386/dist/firefox/DeerPark.app/Contents/MacOS/chrome/toolkit.jar
IO error: opening /Users/puto/sources/firescape/mozilla/../build/ppc/dist/firefox/DeerPark.app/Contents/MacOS/chrome/toolkit.jar for read : No such file or directory 
 at /System/Library/Perl/Extras/5.8.6/Archive/Zip.pm line 927
        Archive::Zip::Archive::read('Archive::Zip::Archive=HASH(0x1801234)', '/Users/puto/sources/firescape/mozilla/../build/ppc/dist/firef...') called at /Users/puto/sources/firescape/mozilla/build/macosx/universal/fix-buildconfig line 67
        main::fixBuildconfig('/Users/puto/sources/firescape/mozilla/../build/ppc/dist/firef...', '/Users/puto/sources/firescape/mozilla/../build/i386/dist/fire...') called at /Users/puto/sources/firescape/mozilla/build/macosx/universal/fix-buildconfig line 54
/Users/puto/sources/firescape/mozilla/build/macosx/universal/fix-buildconfig: could not read "/Users/puto/sources/firescape/mozilla/../build/ppc/dist/firefox/DeerPark.app/Contents/MacOS/chrome/toolkit.jar": error 4
make[1]: *** [postflight_all] Error 1
make: *** [build] Error 2

Expected Results:  
It should build correctly.
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-02-28 07:35:20 PST
flat-chrome builds are for debugging, I don't see any need to support them in universal configurations
Comment 2 Pu7o 2006-02-28 08:01:06 PST
I find flat chrome builds to be both faster and smaller, so I don't see why it should be "for debugging purposes only", but I guess you know better than me.
Comment 3 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-02-28 08:16:46 PST
According to significant testing, flat chrome takes a lot longer to startup because of disk IO: combining files in a JAR is significantly less overall stat+read IO.

Note You need to log in before you can comment on or make changes to this bug.