Dynamic HTML that works in Win32 IE4+ & Navigator 4.08+ don't work in Win32 Mozilla M14

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Ryan Germann, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Please visit

http://www.hotmetalpro.com/

using Win32 Navigator 4.08+ or MSIE 4.01+, and compare behaviour to Mozilla M14.

Comment 1

18 years ago
Changing component to DOM
Assignee: troy → jst
Component: Layout → DOM Level 0
QA Contact: petersen → desale
Target Milestone: ---

Comment 2

18 years ago
the page evaluates for document.all or document.layers in order to do the 
dHTML.  Wouldn't that make this the page writers problem?

important part of the code:
var NS4 = (document.layers) ? 1 : 0;
var IE4 = (document.all) ? 1 : 0;

if ((document.layers) || IE4){
and here it makes the array that it uses in all its functions and stuff.
}




fullish code:

<!--
var NS4 = (document.layers) ? 1 : 0;
var IE4 = (document.all) ? 1 : 0;
var ver4 = (NS4 || IE4) ? 1 : 0;

var topOffset = 113;
var leftOffset = 83;
var buttonHeight = 22;
var pageisloaded = false;

if ((document.layers) || IE4)
	{
 var popupArray = new Array
("popupSoftquadlogo","popupProducts","popupBuynow","popupPartners","popupPress",
"popupSupport","popupRegister","popupResources","popupContact","popupSearch","po
pupSitemap","popupXmetal","popupSoftquad");
	}

var imgProductsover='/images/navbar/hotmetalpro/over/products.gif';
var imgBuynowover='/images/navbar/hotmetalpro/over/buynow.gif';
var imgPartnersover='/images/navbar/hotmetalpro/over/partners.gif';
var imgPressover='/images/navbar/hotmetalpro/over/press.gif';
var imgSupportover='/images/navbar/hotmetalpro/over/support.gif';
var imgRegisterover='/images/navbar/hotmetalpro/over/register.gif';
var imgResourcesover='/images/navbar/hotmetalpro/over/resources.gif';
var imgContactover='/images/navbar/hotmetalpro/over/contact.gif';
var imgSearchover='/images/navbar/hotmetalpro/over/search.gif';
var imgSitemapover='/images/navbar/hotmetalpro/over/sitemap.gif';
var imgXmetalover='/images/navbar/hotmetalpro/over/xmetal.gif';
var imgSoftquadover='/images/navbar/hotmetalpro/over/softquad.gif';
var imgHotmetalproover='/images/navbar/hotmetalpro/sqlogo.gif';

var imgProductsbase='/images/navbar/hotmetalpro/default/products.gif';
var imgBuynowbase='/images/navbar/hotmetalpro/default/buynow.gif';
var imgPartnersbase='/images/navbar/hotmetalpro/default/partners.gif';
var imgPressbase='/images/navbar/hotmetalpro/default/press.gif';
var imgSupportbase='/images/navbar/hotmetalpro/default/support.gif';
var imgRegisterbase='/images/navbar/hotmetalpro/default/register.gif';
var imgResourcesbase='/images/navbar/hotmetalpro/default/resources.gif';
var imgContactbase='/images/navbar/hotmetalpro/default/contact.gif';
var imgSearchbase='/images/navbar/hotmetalpro/default/search.gif';
var imgSitemapbase='/images/navbar/hotmetalpro/default/sitemap.gif';
var imgXmetalbase='/images/navbar/hotmetalpro/default/xmetal.gif';
var imgSoftquadbase='/images/navbar/hotmetalpro/default/softquad.gif';


function hideAllLayers()
     {
     if (pageisloaded)
          {
          for (var i = 0; i < popupArray.length; i++)
               {
               if (document.layers)
                    {
                    document.layers[popupArray[i]].visibility = "hide";
                    }
               else if (document.all)
                    {
                    document.all[popupArray[i]].style.visibility = "hidden";
                    }
               }
          }
     }

function popUp(menuName)
     {
     if (pageisloaded)
          {
          hideAllLayers();
          if (document.layers)
               {
               document.layers[menuName].visibility = "show";
               }
          else if (document.all)
               {
               document.all[menuName].style.visibility = "visible";
               }
          }
     }

//-->
(Assignee)

Comment 3

18 years ago
Yes, resolutionjones is right, this page uses non-supported non-standard
features, ryan, for more info on this please have a look at

      http://sites.netscape.net/ekrock/standards.html

Markin this bug as INVALID due to the use of document.all and document.layers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 4

18 years ago
Layers not supported. Marking verified.
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
Shouldn't this be Evangelism component?
You need to log in before you can comment on or make changes to this bug.