Closed Bug 329029 Opened 14 years ago Closed 14 years ago

Camino and Firefox repeatedly crash on certain pages, e.g. - mail.yahoo.com

Categories

(Core :: Plug-ins, defect, critical)

1.8 Branch
PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: julayok, Unassigned)

Details

Attachments

(1 file, 7 obsolete files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/312.8 (KHTML, like Gecko) Safari/312.5
Build Identifier: Camino 2006021400 (v1.0) and Firefox 1.5.0.1

I have tried downloading and installing camino and firefox multiple times with the same results.  It will perform normally for any where from 5 minuted to 10 hours, and then a URL that would not have been making Camino crash will all of a sudden make it crash.  After this point, the crash is repeatable.  If I reinstall, not problems for a while, then a crash again on the same page.  Other URL's include http://Http://www.morningstar.com and http://nytimes.com/

Reproducible: Always

Steps to Reproduce:
1.open Camino (or Firefox)
2.type mail.yahoo.com into url bar
3.watch Camino (and Firefox) crash

Actual Results:  
Camino crashes.  

Expected Results:  
Not crashed, loaded page.

Ref. Talkback Incident ID: TB15801360X (Camino), TB15801375Q (Camino), TB15800847 (Firefox), TB15763150Y (Firefox), amongst many, many others.

I was unable to find the crash log anywhere in my machine.  Sorry.  I am running Mac OS 10.3.9 on a 900Mhz G3 iBook with 640 M SDRAM.  These are not problems with Safari 1.3.2 (v312.5).
Hmmm, it has never happened to me, i use yahoo mail several times a day with no problems, but I am using Mac OS X 10.4.5...
> I was unable to find the crash log anywhere in my machine.

Open the Console application (in Applications/Utilities), File-> Open... ->Crash Reporter->Camino.crash.log (or Firefox.crash.log). Attach (not paste) one of theese to the bug.

However, since this affects both Camino and Firefox this belongs in Core and not Camino (and juding from the Talkback reports it is a plugin problem...).
Component: General → Plug-ins
Product: Camino → Core
Version: unspecified → 1.8 Branch
The crash report is not there.(In reply to comment #2)
> Open the Console application (in Applications/Utilities), File-> Open...
> ->Crash Reporter->Camino.crash.log (or Firefox.crash.log). Attach (not paste)
> one of theese to the bug.

The Caino.crash.log is not there.  It is nowhere.  The only things in that folder are:
Product Registration.crash.log
Stuffit Expander.crash.log


Talkback seems to eat crash logs. Disable Talkback, then get the crash to happen again and there should be a log in there.

cl
(In reply to comment #4)
> Talkback seems to eat crash logs. Disable Talkback, then get the crash to
> happen again and there should be a log in there.
> 
> cl
> 

I tried disabling TB and reiterating the crash, but log was filed in the console's crash reporter folder.  The only thing that I could find was on the main console screen.  It read:

*** malloc_zone_malloc[713]: argument too large: 4294967284
2006-03-02 22:14:26.038 Camino[720] Unable to set languages - language 'English' not a valid ISO language identifier
*** malloc_zone_malloc[720]: argument too large: 4294967284
2006-03-02 22:15:44.739 Camino[724] Unable to set languages - language 'English' not a valid ISO language identifier
*** malloc_zone_malloc[724]: argument too large: 4294967284

Attached file Console log with some crash data (obsolete) —
Attached file Another console.log with crash data (obsolete) —
Attached file Console.log.5 w/crash data (obsolete) —
Attached file Console.log.6 w/crash data (obsolete) —
Attached file console.log.7 w/crash data (obsolete) —
Attached file console.log.8 w/crash data (obsolete) —
O apologize if any of the data in those crash logs are redundant.  I figured better safe than sorry, and I'm not a developer, so I didn't feel comfortable making the "redundancy" judgement call.

(In reply to comment #11)
> Created an attachment (id=213862) [edit]
> console.log.8 w/crash data
> 

My wife runs a 500Mhz Powerbook G4 on OS 10.3.9, and her machine has the same problems as mine with Camino 1.0.
Attached file camino.crash.log (obsolete) —
Although I still can't find the camino.crash.log on my machine, the camino crash on my wife's machine creates a log (the one attached).
I know the recently submitted camino.crash.log doesn't seem to have any log of a camino 1.0 crash (the dump always says it's camino 0.8.4), but it is the only camino.crash.log on found in the console, and no matter how mnay times I crash Camino 1.0, there's no dump identifying the itself as belonging to 1.0.
Attachment #216700 - Attachment mime type: application/octet-stream → text/plain
(In reply to comment #15)
> I know the recently submitted camino.crash.log doesn't seem to have any log of
> a camino 1.0 crash (the dump always says it's camino 0.8.4), but it is the only
> camino.crash.log on found in the console, and no matter how mnay times I crash
> Camino 1.0, there's no dump identifying the itself as belonging to 1.0.
 
This is probably because Talkback is eating them (see comment 4).

The console logs you're attaching are useless (but thanks for trying, it really *is* appreciated); we need a Camino.crash.log with this specific crash (1.0, not 0.8.4) in it.

From what I can see in the Talkback links you pasted in the bug report, this is a plug-in problem. Are you running the latest version of the Flash plugin? If you turn on ad-blocking, does the problem go away?

cl
I tried disabling talkback on my wife's laptop, and the 1.0 crash dump still wasn't in the log.  I installed newest flash and shockwave, disabled block pop-ups, and 1.0 still crashes.  The most recent TB ID's (the one's after installing the new plug-ins and disaqbling block pop-ups) are:  TB17051760G and TB17051790Y.
Comment on attachment 216700 [details]
camino.crash.log

This log is really from Camino 0.8.4 in Nov of 2005; it's not relevant here.

If you open the Mac OS X Terminal.app, paste in the following command, and hit retrun, what is the result?

defaults read com.apple.CrashReporter LogCrashes
Attachment #216700 - Attachment is obsolete: true
The consle.logs don't have anything useful in them.  This attachment contains all of Seamus's talkback logs to date since they'll disappear shortly (except the first two Camino incidents were identical, so only one of them's here.)

Seamus, the other thing you should try is removing all the Flash and Shockwave plugin files from /Library/Internet Plug-ins (and/or ~/Library/Internet Plug-ins), deleting the pluginreg.dat file from your Camino and Firefox profiles, and then launching Camino/Fx and visiting the page again and seeing if it still crashes (it shouldn't, at least).

Morningstar.com seems to have Flash ads (rather obnoxious ones, at that), but they aren't crashing here, either with ad-blocking on or off, 10.3.9, Flash 8.0r22.
Attachment #213857 - Attachment is obsolete: true
Attachment #213858 - Attachment is obsolete: true
Attachment #213859 - Attachment is obsolete: true
Attachment #213860 - Attachment is obsolete: true
Attachment #213861 - Attachment is obsolete: true
Attachment #213862 - Attachment is obsolete: true
Fixing the owner/QA; apologies for bugspam.
Assignee: mikepinkerton → nobody
QA Contact: plugins
>Seamus, the other thing you should try is removing all the Flash and Shockwave
>plugin files from /Library/Internet Plug-ins (and/or ~/Library/Internet
>Plug-ins), deleting the pluginreg.dat file from your Camino and Firefox
>profiles, and then launching Camino/Fx and visiting the page again and seeing
>if it still crashes (it shouldn't, at least).

This did solve the crash problems on that site (morningstar.com).  However, when I tried to then go and download flash again, Camino crashed, and it does crash every time I go to the micromedia website and try to dl Flash by clicking on the download tab.  THEN, when I opened Camino again and tried to open the morningstar.com page, it crashed again!  I repaired permissions on my hard drive just to make sure that wasn't a problem.  I'll give you the newest TB ID's (now that I've deleted flash and shockwave and the .dat file), as soon as the TB client can connect with the TB server (they're in Queue).

>Morningstar.com seems to have Flash ads (rather obnoxious ones, at that), but
>they aren't crashing here, either with ad-blocking on or off, 10.3.9, Flash
>8.0r22.

Is it possible that I have an important file (or files) that has been corrupted or gone missing?  I also occasionally use Micromat TechTool Pro 4.0 to defrag.  Could this be the source of the problem?  Perhaps this might be why both my wife and I are having the same problem on each of our Apple laptops.  It is nonetheless curious that there are still no problems running Safari 1.3.2 (v312.6), though, on any site.  If this is something on my end, I'm going to feel like a real a-hole.
TB logs (starting with most recent) after deleting flash and shockwave and the pluginreg.dat files:  TB17146133Y, TB17146131H, TB17146129W, TB17146127E, TB17146123Z, TB17146121K, TB17146113E, TB17146112H, TB17146105W, TB17146104Z, TB17106553Q
(In reply to comment #21)
> I repaired permissions on my hard
> drive just to make sure that wasn't a problem.

I think you need to do more than repair permissions there. Try running Verify Disk and see if that finds anything, because I suspect there's a deeper problem at work here. I see you're still getting plugin crashes, despite having removed the Shockwave and Flash plugin stuff.

cl
Reinstall of OS X system software (not a complete overwrite) resolved the issue.  I'm not sure how it is that Mozilla products were the only one's affected and Safari was fine, but so are the mysteries.  I'm sorry to expend y'all's energy for what seems to have been some corrupt file somewhere that Disk Repair couldn't find.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Not FIXED, because there was no code fix on our end.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.