MinGW build error due to Bug #328820

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: David G King, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Patch from Bug #328820 causes the following build error

e:/mozilla/source/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:557: error:
invalid
 static_cast from type `NS_ConvertASCIItoUTF16' to type `nsAString_internal&'
Assignee: general → nobody
Component: GFX → GFX: Thebes
QA Contact: ian → thebes
(Reporter)

Updated

13 years ago
Blocks: 203303
Component: GFX: Thebes → GFX
(Reporter)

Updated

13 years ago
Blocks: 311993
Component: GFX → GFX: Thebes

Comment 1

12 years ago
The problem described in this was due to the following line
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/gfx/thebes/src/gfxWindowsFonts.cpp&rev=1.20&root=/cvsroot&mark=557#550

However, I am not able reproduce it.  Do you still encounter it using an up-to-date version of MinGW?
(Reporter)

Comment 2

12 years ago
If I remember correctly a fix was checked in with a different bug. Resolving.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 3

12 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.