Closed Bug 329100 Opened 17 years ago Closed 17 years ago

"Customize..." window is missing items, disables all menus on close.

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 2 alpha2

People

(Reporter: hsumen, Assigned: annie.sullivan)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060302 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060302 Firefox/1.6a1

See summary.

Reproducible: Always

Steps to Reproduce:
1.Right-click a toolbar, choose "Customize..."
2.Close the Customize window.
3.

Actual Results:  
Many toolbar items are missing, closing the window disables all menus on the menubar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
That happens when you use a localstore.rdf of a previous non-places build where you had reorganized your toolbars or icons. Deleting the file will help but I'm afraid this will not be an acceptable solution for most of the users.
Assignee: nobody → annie.sullivan
Priority: -- → P2
Target Milestone: --- → Firefox 2 alpha2
OS: Windows XP → All
Hardware: PC → All
Seems to have been fixed in the 20060304 trunk.  WFM.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060304 Firefox/1.6a1 - Build ID: 2006030404
Well it works with a new profile but otherwise I had to delete localstore.rdf a second time (thx for the tip Ria).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060304 Firefox/1.6a1 - Build ID: 2006030402
(In reply to comment #1)
> That happens when you use a localstore.rdf of a previous non-places build where
> you had reorganized your toolbars or icons. Deleting the file will help but I'm
> afraid this will not be an acceptable solution for most of the users.
> 

I'm not seeing this, even if I follow these instructions.  It sounds like a JavaScript error has occurred in the BrowserToolboxCustomizeDone() function in browser.js, before the menubar gets re-enabled.  Do you get any JavaScript errors when you close the customize palette?  I see one in reporter.js about gBrowser not being defined when I open the palette, but it doesn't seem to have any affect.
(In reply to comment #4)
>
I saw only the missing stuff in the customize window but this was fixed by one of the other similar bugs filed at the same time. I've never seen the disabled menus.
Marking this fixed, since I think it was fixed by the fixes to bugs 327479 and 327364. If anybody sees the disabled menus problem please re-open, and post JavaScript errors if possible.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.