Last Comment Bug 329143 - Border style of "non-visible" case is shown
: Border style of "non-visible" case is shown
Status: RESOLVED WONTFIX
:
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: ---
Assigned To: xforms
: Stephen Pride
:
Mentors:
http://www.w3.org/TR/xforms/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 12:54 PST by Allan Beaufour
Modified: 2016-07-15 14:46 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Testcase (1.11 KB, application/xhtml+xml)
2006-03-02 12:54 PST, Allan Beaufour
no flags Details

Description Allan Beaufour 2006-03-02 12:54:15 PST
If I set a border style on cases, the border style on the non-visible ones are still shown on the page.
Comment 1 Allan Beaufour 2006-03-02 12:54:43 PST
Created attachment 213787 [details]
Testcase
Comment 2 Allan Beaufour 2006-05-31 05:00:53 PDT
The problem is that a style rule like:
xf|case {
  border: 1px solid blue;
}
targets the case element itself, while we set the display attribute on the div we create inside the case. This means that this will work now:
xf|case > div {
  border: 1px solid blue;
}
But obviously we do not want that. Styling the case should be enough.
Comment 3 David Bolter [:davidb] 2016-02-04 12:21:40 PST
RIP xforms

Note You need to log in before you can comment on or make changes to this bug.