"ASSERTION: Popup attached to an element that isn't in XUL!" when ctrl+clicking XUL textbox in XHTML page

VERIFIED FIXED

Status

()

VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

({assertion, testcase})

Trunk
assertion, testcase
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

207 bytes, application/xml
Details
(Reporter)

Description

13 years ago
Steps to reproduce:
1. Load the testcase.
2. Ctrl+click the textbox (testing on Mac, where Ctrl+click is equivalent to right-click).

Result: 

###!!! ASSERTION: Popup attached to an element that isn't in XUL!: 'Error', file /Users/admin/trunk/mozilla/content/xul/content/src/nsXULPopupListener.cpp, line 282

Expected:

Context menu with items like "Paste" and "Undo".
(Reporter)

Comment 1

13 years ago
Created attachment 214062 [details]
testcase
Depends on: 279703
*** Bug 356769 has been marked as a duplicate of this bug. ***
Component: XUL Widgets → XP Toolkit/Widgets: XUL
OS: Mac OS X 10.2 → All
Product: Toolkit → Core
QA Contact: xul.widgets → xptoolkit.xul
Hardware: Macintosh → All
Should now be fixed with bug 279703.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

12 years ago
The assertion is gone, but the context menu still fails to appear.  I filed bug 386938 for that.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

11 years ago
I don't think it makes sense to make an automated test for this before bug 386938 is fixed.
Flags: in-testsuite-

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.