If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

radii of canvas radialGradient on thebes build are incorrect

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Takeshi Kurosawa, Assigned: vlad)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060306 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060306 Firefox/1.6a1

canvas radialGradient are rendered wrong on cairo-gtk2.
This isn't happened on gtk2.

Reproducible: Always
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060306 Firefox/1.6a1 ID:0000000000
I don't know which one's the correct rendering, but they're certainly different.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

12 years ago
Summary: canvas radialGradient are rendered incorrent on cairo-gtk2 → canvas radialGradient on cairo-gtk2 are different from on gtk2

Updated

12 years ago
Depends on: 334512

Updated

12 years ago
Blocks: 334512
No longer depends on: 334512
Blocks: 334730
No longer blocks: 334512
Assignee: nobody → vladimir

Comment 2

11 years ago
screenshot?
(Reporter)

Comment 3

11 years ago
Created attachment 246355 [details]
Screenshot

Screenshot with official nightly trunk build and official 1.8 branch build.
(Reporter)

Comment 4

11 years ago
This is reproduced on Windows XP/Trunk Nightly
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070208 Minefield/3.0a3pre

And IMHO, It seems radii of the gradients cause it.
Blocks: 334737
No longer blocks: 334730
Summary: canvas radialGradient on cairo-gtk2 are different from on gtk2 → radii of canvas radialGradient on thebes build are incorrect
(Reporter)

Comment 5

11 years ago
After cairo updated to 1.4.2 (Bug 374462), this seems to be fixed.
-> FIXED
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.