Closed Bug 32954 Opened 20 years ago Closed 20 years ago

Mozilla crashes when "Exit" is selected in any Profile managing window.

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3, major)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 32485

People

(Reporter: jelwell, Assigned: racham)

References

Details

Steps to reproduce:
1)Launch mozilla -ProfileManager
2)Click Exit
*crash*

The error message I get is an "OleMainThreadWndName: mozilla.exe - Application
Error" and is odd because normally Visual C++ will ask me if I want to debug
crashes, but it doesn't when I crash mozilla in this manner.

I'm using winNT build 2000032210.
This looks like something we've seen before...
Assignee: selmer → racham
*** Bug 32972 has been marked as a duplicate of this bug. ***
I'm seeing this too.  It hasn't always crashed when hitting exit, but I'm not 
sure when this regression popped up.
Status: NEW → ASSIGNED
Target Milestone: --- → M15
This bug may very well be a dup og bug 32485. Once I get the stack trace, I will  
see if I need to mark it as a dup.
Same stack trace. Marking this as a dup 32485.

nsXPCWrappedNativeClass::GetArbitraryScriptable() line 820 + 25 bytes
nsXPCWrappedNative::GetArbitraryScriptable() line 1000 + 22 bytes
nsXPCWrappedNative::JSObjectFinalized(JSContext * 0x010282c0, JSObject * 
0x00ebb170) line 89 + 25 bytes
WrappedNative_Finalize(JSContext * 0x010282c0, JSObject * 0x00ebb170) line 679
js_FinalizeObject(JSContext * 0x010282c0, JSObject * 0x00ebb170) line 1470 + 114 
bytes
js_GC(JSContext * 0x010282c0) line 898 + 11 bytes
js_ForceGC(JSContext * 0x010282c0) line 678 + 9 bytes
js_DestroyContext(JSContext * 0x010282c0, int 2) line 183 + 9 bytes
JS_DestroyContext(JSContext * 0x010282c0) line 794 + 11 bytes
PREF_CleanupPrefs() line 562 + 13 bytes
PREF_Cleanup() line 547
nsPref::ShutDown(nsPref * const 0x00ffd200) line 326
nsPref::~nsPref() line 175
nsPref::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsPref::Release(nsPref * const 0x00ffd200) line 256 + 135 bytes
nsScriptSecurityManager::~nsScriptSecurityManager() line 1071 + 27 bytes
nsScriptSecurityManager::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsScriptSecurityManager::Release(nsScriptSecurityManager * const 0x013cd1f0) 
line 308 + 154 bytes
nsJSUtils::nsClearCachedSecurityManager() line 695 + 17 bytes
nsJSEnvironment::~nsJSEnvironment() line 883
nsJSEnvironment::`scalar deleting destructor'(unsigned int 1) + 15 bytes
JSEnvironmentInit::~JSEnvironmentInit() line 831 + 30 bytes
$E6() + 13 bytes
_CRT_INIT(void * 0x00490000, unsigned long 0, void * 0x00000001) line 236
_DllMainCRTStartup(void * 0x00490000, unsigned long 0, void * 0x00000001) line 
289 + 17 bytes
NTDLL! 77f69dca()
KERNEL32! 77f19ffb()
doexit(int 1, int 0, int 0) line 392
exit(int 1) line 279 + 13 bytes
mainCRTStartup() line 345
KERNEL32! 77f1ba06()


*** This bug has been marked as a duplicate of 32485 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
dupe
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.