Browser context menu issue with "Bookmark this Page" option

VERIFIED DUPLICATE of bug 10198

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED DUPLICATE of bug 10198
18 years ago
14 years ago

People

(Reporter: Robert John Churchill, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Bill, it looks like the "Bookmark this Page" context menu option is enabled, 
even if the URL in question has already been bookmarked.

It would be great if this was a bit smarter... and the option not available if 
the URL in question is already bookmarked.

There is a function on the nsIBookmarksService that you can call:  
    IsBookmarked()
    [it returns PR_TRUE if a URL is already in the user's bookmarks]
before deciding whether to call AddBookmark() or not.

Comment 1

18 years ago
Similar to bug 10198.  I'd rather warn than disable - what if you actually want 
the bookmark in two places?  What if you would like to be able to figure out 
where the bookmark is by clicking the "bookmark this page" option.
(Reporter)

Comment 2

18 years ago
I'd suggest that 10198 be marked as a DUP of this bug, as this bug has detailed 
info on how to check for see if a URL has already been bookmarked.

Comment 3

18 years ago
I'd also like to throw my vote in the direction of Warn, not Disable.  Users
will not always make the connection with why the item is disabled and may think
that it is a bug or that the page can not be bookmarked.  Remember that many
users have hundreds of bookmarks and don't always remember every one they have
bookmarked.

Updated

18 years ago
Target Milestone: --- → Future
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Component: Browser-General → Bookmarks
QA Contact: asa → claudius

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 10198 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Vfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.