Last Comment Bug 329669 - Views don't update after changing timezone setting - restart required
: Views don't update after changing timezone setting - restart required
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Joey Minta
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 13:23 PST by Stefan Sitter
Modified: 2006-08-22 06:42 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
add timezone.local to pref listener (7.73 KB, patch)
2006-03-26 08:05 PST, Joey Minta
dmose: first‑review+
Details | Diff | Review

Description Stefan Sitter 2006-03-07 13:23:06 PST
Views don't update after changing timezone setting - restart required

Steps to reproduce:

0) If not done yet: Go to Lightning pane in Thunderbird options/preferences
   dialog select a timezone (e.g. Europe/Berlin (UTC+1)) and restart Thunderbird

1) Create an test event and note start time / end time

2) Go to Lightning pane in Thunderbird options/preferences dialog. Select
   a different timezone (e.g. America/Los_Angeles (UTC-8)). Press Ok.

3) Check the created event in the view
   --> Views have not changed, event is displayed as before

4) Restart Thunderbird and check the created event in the view
   --> Event is now displayed with start and end time shifted to new timezone
       (9 hours in this example)

Expected Results:
After changing the timezone settings the views should be updated automatically.
Comment 1 Joey Minta 2006-03-07 14:15:53 PST
Probably depends on landing bug 321608, since that will finish implementing pref-observers in all views.  These observers can then be wired to listen for the timezone pref too.
Comment 2 Joey Minta 2006-03-26 08:05:13 PST
Created attachment 216319 [details] [diff] [review]
add timezone.local to pref listener

Patch adds a listener for calendar.timezone.local to automatically refresh the views.
Comment 3 Dan Mosedale (:dmose) 2006-03-27 14:04:43 PST
Comment on attachment 216319 [details] [diff] [review]
add timezone.local to pref listener

r=dmose
Comment 4 Joey Minta 2006-03-27 18:52:33 PST
Patch checked in.

Note You need to log in before you can comment on or make changes to this bug.