Status

()

Core
XPCOM
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: gng, Assigned: Daniel (Leaf) Nunes)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; I; Linux 2.2.10 i686)
BuildID:    Milestone 14

exporting to remote xserver, crashes on  first startup.
xlogo works, runs on localserver.. after installer runs on local server,
the browser displays fine on the remote display
SUSE Linux 6, XFree 3.x

Reproducible: Always
Steps to Reproduce:
1. Fresh install, Installer program had NOT run yet
Telnet into machine w/ the moz is installed
2.export DISPLAY=blindlemmon:0.0; xlogo
3../mozilla

Actual Results:  crash when installer/profile setup program starts <nothign
displayed>
on remote xserver

Expected Results:  see usersetup/installer program

it only works if you are doing a clean install.. after the installer
runs once , it works ok... weird..huh?
btw.. mozilla is looking great!!!!
gng@hiro-tan.dhs.org - M14 is quite an old build. Could you please download a 
recent nightly build and tell us if the same problem still occurs? Please 
include the Build ID of the build you use.

Gerv
(Reporter)

Comment 2

18 years ago
i submited this bug for M14, i was recomended to grab a nightly build and try to
reproduce it... 
the nightly build:     
6316517 Mar 24 10:10 mozilla-i686-pc-linux-gnu.tar.gz 
2000-03-24-09-M15
< i cant get the build# becuase moz never starts>
mozilla is running on a server, and i am displaying to a remote machine..
this is the output

patton:/tmp/package # xlogo
<works fine>
patton:/tmp/package # ./mozilla
.//run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/tmp/package
  LD_LIBRARY_PATH=/tmp/package::/usr/local/rvplayer5.0
       SHLIB_PATH=/tmp/package
          LIBPATH=/tmp/package
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
**************************************************
nsNativeComponentLoader: SelfRegisterDll(/tmp/package/components/libnsjpg.so)
Load FAILED with error: libjpeg.so.62: cannot open shared object file: No such
file or directory
**************************************************
nNCL: registering deferred (0)
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
.//run-mozilla.sh: line 29:  1416 Segmentation fault      $prog ${1+"$@"}



nsNativeComponentLoader is XPCOM. However, this may not be their problem. Feel 
free to bounce this one back :-)

Gerv
Assignee: cbegle → dp
Component: Browser-General → XPCOM
QA Contact: asadotzler → leger

Comment 4

18 years ago
You need jpeg .so  I think we were planning on changing to include the jpeg 
that is built with the tree. Leaf ?
Assignee: dp → leaf
(Assignee)

Comment 5

18 years ago
dp, it's trying to load libnsjpeg.so... if libnsjpeg.so weren't there, we
wouldn't get that message at all, right? Even if it isn't there, we shouldn't be
segmentation faulting. This might belong to pnunn, but it looks like it's well
after the attempted jpeg load. 

I'll double check now that the nightlies are shipping with a separate jpeg
library.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 6

18 years ago
so, libnsjpeg.so is in the download package, and doesn't seem to reference the
libjpeg.so.62 library at all, so i don't understand the failure of the component
to load. 

I'll do more tests, but even if i'm failing to provide libnsjpg.so, we shouldn't
segfault.
(Assignee)

Comment 7

18 years ago
this is very strange... if i hide my libjpeg.so.62 files, i'm still able to run
today's linux build and view jpegs.

I have no idea where to assign this bug to now... gng, what kind of system are
you on?
Assignee: leaf → leaf
Status: ASSIGNED → NEW
(Reporter)

Comment 8

18 years ago
SUSE 6.x, dual Celeron 360,128mgs, XFree86 3.x <where mozilla is exe'd>

Slackware 7, 133mhz  Toshiba Laptop ,XFree86 3.x via XDM Session  

Comment 9

18 years ago
Adding crash keyword.
Keywords: crash
leaf - did you ever get to the bottom of your puzzlement in this bug?

Gerv
(Assignee)

Comment 11

18 years ago
No, i'm still puzzled. gng, you're still crashing?
Status: NEW → ASSIGNED

Comment 12

18 years ago
akkana:
You run suse at home, don't you?
Have you seen anything that might be
related to this?
-P
(Reporter)

Comment 13

18 years ago
It seems to work w/ the latest Milestone
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

18 years ago
I'll let another suse user verify this, thanks, gng.
- Per last comments, age of bug, and no reopen - Marking Verified/Fixed.  Please 
reopen if still a problem. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.