Last Comment Bug 329796 - Can't debug XForms on Mac OS X
: Can't debug XForms on Mac OS X
Status: RESOLVED FIXED
: fixed1.8.0.4, fixed1.8.1
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: jhp (no longer active)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 09:28 PST by jhp (no longer active)
Modified: 2006-04-28 12:26 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (831 bytes, patch)
2006-03-08 09:29 PST, jhp (no longer active)
doronr: review+
Details | Diff | Splinter Review
patch v2 - global change (969 bytes, patch)
2006-03-16 10:05 PST, jhp (no longer active)
benjamin: review+
benjamin: approval‑branch‑1.8.1+
dveditz: approval1.8.0.4+
Details | Diff | Splinter Review

Description jhp (no longer active) 2006-03-08 09:28:42 PST
Bug 309210 made it so debug symbols are stripped from the xforms lib when packaging it in the XPI.  However, it does the stripping for debug builds also, so I can't set breakpoints when trying to debug XForms.
Comment 1 jhp (no longer active) 2006-03-08 09:29:42 PST
Created attachment 214445 [details] [diff] [review]
patch

Don't strip symbols if MOZ_DEBUG is defined.
Comment 2 Doron Rosenberg (IBM) 2006-03-08 09:47:57 PST
Comment on attachment 214445 [details] [diff] [review]
patch

not really a build config bug, but a xforms bug :)
Comment 3 jhp (no longer active) 2006-03-08 11:23:22 PST
Actually, I'm wondering if we shouldn't wrap the rule in rules.mk with "ifndef MOZ_DEBUG", since I don't really see a reason why we would want to strip if we are building debug.  If not, this forces everyone who defines STRIP_XPI to also wrap it with the ifdef.
Comment 4 Allan Beaufour 2006-03-15 07:28:56 PST
Same goes for Linux.
Comment 5 jhp (no longer active) 2006-03-16 10:05:29 PST
Created attachment 215294 [details] [diff] [review]
patch v2 - global change

This should be fixed in rules.mk.  It would be foolish to make all users add the MOZ_DEBUG check around STRIP_XPI.
Comment 6 jhp (no longer active) 2006-03-28 13:44:41 PST
Checked in to trunk. ->FIXED
Comment 7 jhp (no longer active) 2006-03-28 13:47:13 PST
Comment on attachment 215294 [details] [diff] [review]
patch v2 - global change

Asking for approval for both branches.  Without this patch, we cannot debug XForms XPI on Mac or Linux.
Comment 8 Daniel Veditz [:dveditz] 2006-04-21 13:40:14 PDT
Comment on attachment 215294 [details] [diff] [review]
patch v2 - global change

approved for 1.8.0 branch, a=dveditz for drivers
Comment 9 Daniel Veditz [:dveditz] 2006-04-28 12:00:36 PDT
Code freeze for this release is Monday May 1, at which point approval will be withdrawn from this bug if it's not checked in.

Note You need to log in before you can comment on or make changes to this bug.