Incomplete download reported as complete by Seamonkey

RESOLVED DUPLICATE of bug 237623

Status

RESOLVED DUPLICATE of bug 237623
13 years ago
4 years ago

People

(Reporter: allltaken, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060301 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060301 SeaMonkey/1.5a

After starting a download of the current nightly, the download apparently stalled for unknown reasons (server traffic maybe), and then Seamonkey closed the partial download .par file, renaming it as a zip and indicated in Download Manager that the file was complete. It was not. Only about 8Mb of the 11Mb+ file was fetched.

Reproducible: Sometimes

Steps to Reproduce:
1. Start downloading a large file with Seamonkey
2. Wait for or induce a download stall condition (by a certificate dialog box in mail perhaps)
3. 

Actual Results:  
The download manager window shows the download to be complete, but the filesize is less than the size of the file indicated on the server. In the download location, the file has the correct filename for the completed file.

Expected Results:  
An error condition for an incomplete download should be entered in the download manager's file list (incomlete or failed for example). The name of the incomplete file in the download location should be left as a .par file.

If a problem arose because of bad packets, for example because someone made noise on an extension phone during a dialup download, the download code should work with the server to refetch packets instead of producing a stall condition and download failure. I don't know if this is a cause of stalling, but this has appeared to happen at various times.

Comment 1

13 years ago
Duplicate of/related to Core bug 237623?

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 327623 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
Sorry, wrong dupe :(
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 237623 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.