Missing rows when printing a 2nd table with page-break-after, if 2nd table more than one page and has a nested table

RESOLVED DUPLICATE of bug 132035

Status

()

RESOLVED DUPLICATE of bug 132035
13 years ago
10 years ago

People

(Reporter: st601486, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/417.9 (KHTML, like Gecko) Safari/417.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I'm going to try to attach an example.  Apologies, if I mess up - newbie.

Assume you have a table, directly inside the Body that is defined with <table style="page-break-after: always;">.  Assume the table has one nested table inside it.  (NB: nested table is about as boring as possible).  Assume that the rows, when printed, spill onto a second or third page.

Now assume you have two of these tables, one after the other.

When printed, the second (and any subsequent tables) will not print the rows that would normally fall on the second (or third) page.  Instead, I get a blank page (or two).  Note page-break-after might give me one extra blank page, but it should still print the table rows that would be on the second (or third) page, yes?  

FireFox 1.04, Safari, and Opera will print out the rows on the second page from the second table.  But FireFox 1.5+ on both Mac and Windows (well, the one PC I could use), Camino 1.0, as well as Deer Park 1.6a1 on Mac will print blank pages in place of table rows.

NB: this only seems to affect the second (and subsequent tables) and that a nested table with at least one table data cell seems to be necessary.

Bug 136714 complains about breaks not occuring but does not mention missing table rows.  Also, comments raised the issue of td not being a block level element and the issue of how to handle nested breaks.  In this case, I think a table is a block level element and the page-break-after is not nested ... I don't think.

Bug 202927 (marked as duplicate of above) sounds more similar to this case, but it's kind of hard to tell.

Apologies, if this is something stupid that I'm missing.  And, yes, I think html really isn't designed as a page-layout language and shouldn't be used as such, but ... oh well.  Anyways, thanks in advance for looking at this!

Reproducible: Always

Steps to Reproduce:
1. Open page with two "more-than-one-page" tables with the page-break-after style (I'll try to attach an example in a bit) and with a nested (very boring) table inside.
2. Print or print preview.
3. Look for the rows from the second table that should be on the "third" page.
Actual Results:  
Rows from the second table that should be on the "third" page are missing.  Instead a blank page prints.

Expected Results:  
Even if the page-break-after is ignored, I expect the table rows (and data cells) to print.

Tried (briefly) on three computers.  Two Mac OS X 10.4.x and one Windows XP, SP2.
(Reporter)

Comment 1

13 years ago
Created attachment 214757 [details]
(Ugly) Sample Case that Fails for Me

Updated

13 years ago
Component: General → Layout: Tables
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → 1.0 Branch

Updated

13 years ago
Version: 1.0 Branch → Trunk
(Reporter)

Updated

13 years ago
OS: MacOS X → All
(Reporter)

Comment 2

13 years ago
Hi,

Tried out my test case on a Kubuntu box running a freshly downloaded and installed version of firefox (1.5.0.1).  Still fails.  Updating from Mac OS X to all - seems close to all.

thx
Hardware: Macintosh → All

Comment 3

12 years ago
I believe that this may have the same cause as https://bugzilla.mozilla.org/show_bug.cgi?id=370291 "nested tables with align="left" and a nonwrapping string only print the first page"

I've a test case there.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 132035
You need to log in before you can comment on or make changes to this bug.