Last Comment Bug 330190 - Change widgets to use initEvent(..., true, true); for backwards compatibility
: Change widgets to use initEvent(..., true, true); for backwards compatibility
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: events
: Hixie (not reading bugmail)
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 234455
  Show dependency treegraph
 
Reported: 2006-03-11 13:57 PST by neil@parkwaycc.co.uk
Modified: 2006-03-14 09:06 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (22.01 KB, patch)
2006-03-11 14:10 PST, neil@parkwaycc.co.uk
bryner: review+
bugs: review+
jag-mozilla: superreview+
Details | Diff | Splinter Review
branch patch, to keep widgets in sync (18.01 KB, patch)
2006-03-14 07:22 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
neil: approval‑branch‑1.8.1+
Details | Diff | Splinter Review
fixed branch patch [checked in] (18.78 KB, patch)
2006-03-14 07:30 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2006-03-11 13:57:40 PST
Prior to bug 234455 events always bubbled through XUL elements. We should maintain compatibility by fixing all our calls to initEvent.
Comment 1 neil@parkwaycc.co.uk 2006-03-11 14:10:32 PST
Created attachment 214795 [details] [diff] [review]
Proposed patch

This includes backouts of the tabbrowser.xml changes from bug 234455.
Comment 2 neil@parkwaycc.co.uk 2006-03-11 14:11:39 PST
Comment on attachment 214795 [details] [diff] [review]
Proposed patch

Just checking that what I've done for radio.xml matches the new event system.
Comment 3 Olli Pettay [:smaug] 2006-03-12 03:00:30 PST
Comment on attachment 214795 [details] [diff] [review]
Proposed patch

Looks right to me.
So you are backing out my changes to tabbrowser.xmls because you fix events to bubble.
Radio.xmls look right too, there the 'select' event is created using .initEvent("select", false, true) so no need to call .preventBubble().
Thanks for doing this!
Comment 4 Olli Pettay [:smaug] 2006-03-12 03:43:28 PST
(I wonder one thing... why initEvent("evenName", false, true) has been used so often...)
Comment 5 jag (Peter Annema) 2006-03-12 03:46:13 PST
Comment on attachment 214795 [details] [diff] [review]
Proposed patch

Smaug: I suspect it's a simple matter of copy&paste :-)

sr= on the xpfe changes
Comment 6 Jon Westgate 2006-03-12 06:07:49 PST
I tried this patch and installed multizilla, it worked a dream.
Without this patch only the first tab on multizilla is connected to the url bar
although new tabs appear and will open a new page if you right click links and select open in new tab.
New tabs are not connected to the url bar. Any url entered opens in the first tab.
Comment 7 Brian Ryner (not reading) 2006-03-12 11:31:07 PST
Comment on attachment 214795 [details] [diff] [review]
Proposed patch

r=me on the toolkit patch if you'd like.
Comment 8 neil@parkwaycc.co.uk 2006-03-12 13:05:07 PST
Fix checked in.
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-03-14 07:22:49 PST
Created attachment 215016 [details] [diff] [review]
branch patch, to keep widgets in sync

Minus the tabbrowser and
Comment 10 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-03-14 07:24:11 PST
(In reply to comment #9)
> Created an attachment (id=215016) [edit]
> Minus the tabbrowser and 

... radio.xml changes. As I understand it, the parameter has no effect on the branch, so this patch essentially does nothing but keep things in sync.
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-03-14 07:30:48 PST
Created attachment 215017 [details] [diff] [review]
fixed branch patch [checked in]

This includes all the initEvent changes from this bug, plus the initEvent changes from attachment 214345 [details] [diff] [review] of bug 234455 (to colorpicker.xml).
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-03-14 09:06:54 PST
Comment on attachment 215017 [details] [diff] [review]
fixed branch patch [checked in]

Checked in on the 1.8 branch, 2006-03-14 09:05.

Note You need to log in before you can comment on or make changes to this bug.