mimgw:unable to build due to error in gfxPlatform.cpp

RESOLVED DUPLICATE of bug 328499

Status

()

--
major
RESOLVED DUPLICATE of bug 328499
13 years ago
13 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
I'm using gcc under windows and I get:

In file included from d:/Mozilla/mozilla/gfx/thebes/src/gfxPlatform.cpp:41:
../../../dist/include/thebes/gfxWindowsPlatform.h:47:19: mlang.h: No such file o
r directory
In file included from d:/Mozilla/mozilla/gfx/thebes/src/gfxPlatform.cpp:41:
../../../dist/include/thebes/gfxWindowsPlatform.h:65: error: ISO C++ forbids dec
laration of `IMultiLanguage' with no type
../../../dist/include/thebes/gfxWindowsPlatform.h:65: error: expected `;' before
 '*' token
../../../dist/include/thebes/gfxWindowsPlatform.h:75: error: `IMultiLanguage' wa
s not declared in this scope
../../../dist/include/thebes/gfxWindowsPlatform.h:75: error: template argument 1
 is invalid
../../../dist/include/thebes/gfxWindowsPlatform.h:75: error: ISO C++ forbids dec
laration of `mMLang' with no type
make[6]: *** [gfxPlatform.o] Error 1
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 328499 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.