Closed Bug 330391 Opened 14 years ago Closed 11 years ago

Add tooltips to events in the Agenda / Today Pane

Categories

(Calendar :: Lightning Only, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: keria, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Lightning 0.1 RC2 (build: 2006031011)

When the mouse hovers over an event, a box should pop up showing extra information (location, description, attendees etc.) about the event.

Reproducible: Always

Steps to Reproduce:
That is a good idea. 
I once tried to achieve this using the code that already exists in Sunbird; but that was not as easy as I thought. First this code needs some cleanup and removing of global vars. The patch in Bug 322768 will help to achive this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: When mouse over an event, extra information should show up in a windows. → Show tooltip/preview with event/task details on mouse over
Version: unspecified → Trunk
I previously removed dependencies in mouseoverPreviews.js on gCalendarWindow and on dateUtil.js.  This patch removes the final dependency, gCalendarBundle and then makes the necessary changes to actually get these tooltips wired up in the views.  It still remains to get tooltips for the agenda-tree and tasklist, but I think this is a decent start.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #221507 - Flags: first-review?(dmose)
Comment on attachment 221507 [details] [diff] [review]
remove gcalendarbundle deps and implement

>+  <tooltip id="itemTooltip"
>+           noautohide="true"/>
>+

This doesn't deserve two lines.  Spare the text density, spoil the XUL, or something.

> /** String for event status: (none), Tentative, Confirmed, or Cancelled **/
> function getEventStatusString(calendarEvent)
> {
>+  var sbs = Components.classes["@mozilla.org/intl/stringbundle;1"]
>+                      .getService(Components.interfaces.nsIStringBundleService);
>+  var props = sbs.createBundle("chrome://calendar/locale/calendar.properties");

Everyone together now!

> {
>+  var sbs = Components.classes["@mozilla.org/intl/stringbundle;1"]
>+                      .getService(Components.interfaces.nsIStringBundleService);
>+  var props = sbs.createBundle("chrome://calendar/locale/calendar.properties");

o/~ O how we do love our helpers o/~

>+  var sbs = Components.classes["@mozilla.org/intl/stringbundle;1"]
>+                      .getService(Components.interfaces.nsIStringBundleService);
>+  var props = sbs.createBundle("chrome://calendar/locale/calendar.properties");

o/~ God bless them, every one o/~

r=shaver
Attachment #221507 - Flags: first-review?(dmose) → first-review+
patch checked in.  Leaving bug open to add tooltips to the agenda tree.
Summary: Show tooltip/preview with event/task details on mouse over → Add tooltips to events in the agenda tree
Re-assigning my bugs to nobody@mozilla.org due to recent developments.
Assignee: jminta → nobody
Status: ASSIGNED → NEW
Summary: Add tooltips to events in the agenda tree → Add tooltips to events in the Agenda / Today Pane
Version: Trunk → unspecified
Duplicate of this bug: 415074
Keywords: helpwanted
Works for me using Lightning 1.0pre (20090304) with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090304 Shredder/3.0b3pre.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.