Last Comment Bug 330396 - Output with illegal bind not set irrelevant
: Output with illegal bind not set irrelevant
Status: RESOLVED DUPLICATE of bug 313118
:
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: aaronr
: Stephen Pride
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-13 15:47 PST by aaronr
Modified: 2016-07-15 14:46 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase (1.64 KB, application/xhtml+xml)
2006-03-13 15:48 PST, aaronr
no flags Details

Description aaronr 2006-03-13 15:47:01 PST
As per model-construct-done processing, all controls bound to a node that doesn't exist, should behave as if they are bound to an irrelevant node.  All of our controls in this situation don't show up.  EXCEPT the output control.
Comment 1 aaronr 2006-03-13 15:48:59 PST
Created attachment 214946 [details]
testcase
Comment 2 Stephen Pride 2006-04-10 08:28:03 PDT
It appears that simply doing a cut-n-paste of the following code from nsXFormsControlStub.cpp to nsXFormsOutputElement.cpp fixes the problem ...

  } else if (mModel) {
    // we should have been successful.  Must be pointing to a node that
    // doesn't exist in the instance document.  Disable the control
    // per 4.2.2 in the spec

    nsCOMPtr<nsIXTFElementWrapper> xtfWrap(do_QueryInterface(mElement));
    NS_ENSURE_STATE(xtfWrap);
    xtfWrap->SetIntrinsicState(NS_EVENT_STATE_DISABLED);

    // Dispatch event
    nsXFormsUtils::DispatchEvent(mElement, eEvent_Disabled);
  }

... but I need to check if doing so doesn't break something else and/or violate the spec in some way.
Comment 3 Allan Beaufour 2006-04-10 08:35:12 PDT
I'm pretty sure that this will be fixed as part of bug 313118. I'm currently working on that.
Comment 4 Allan Beaufour 2006-04-19 01:25:05 PDT
This is fixed by bug 313118.

*** This bug has been marked as a duplicate of 313118 ***

Note You need to log in before you can comment on or make changes to this bug.