selection/repaint problems - display not updating

VERIFIED DUPLICATE of bug 25258

Status

()

P3
normal
VERIFIED DUPLICATE of bug 25258
19 years ago
19 years ago

People

(Reporter: puetzk, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Mozilla seems to sporadically (though quite often) stop updating it's windows
properly.

Symptoms are:
when text is selected, no 'inverting' happens.
when menuse are pulled down, the little 'tab' at the top doesn't draw
when form buttons/menus/etc are clicked, they don't change to show their new values.
the statusbar quits updating for link moseovers, etc.

Things that help fix it (temporarily):
scrolling (only helps the main pane, not urlbar etc)
xrefresh
windowshade/unwindowshade

all of which would be requesting redraws. so it seems like mozilla knows what to
draw, it just doesn't know when it needs to draw it.

ChrisM in #smoketest says he could see this on MacOS 9 too, I see it on Debian
Linux/PowerPC (potato)
(Reporter)

Comment 1

19 years ago
Hmm... after deleting my profile it went away (for a while) but 15 mins later

it's back.



Just before it started doing this I got a bunch of assertions of the form



Gdk-CRITICAL **: file gdkgc.c: line 288 (gdk_gc_unref): assertion `gc != NULL'

failed



So it looks like maybe mozilla accidently lost it's gc? I don't see these now

(and it's not working) but they got spewed all over just before it broke. Could

be that ChrisM was seeing something else entirely...

(Reporter)

Comment 2

19 years ago
it looks like maybe I'm wrong about forms and select being the same bug - the
forms part of this appears to be a dup of 25258.

I haven't seen the selections freak out in a couple of days, so it looks like
that got fixed w/o me finding the other bug number. I (as the reporter) am going
to mark the remaining issue on this bug as a dup of 25258.


*** This bug has been marked as a duplicate of 25258 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
Rubber-stamping as verified/duplicate, since I haven't seen this issue
personally (other than text selection, which is covered by existing bugs.)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.