Last Comment Bug 330721 - Remove OS/2 VACPP compiler support from NSS
: Remove OS/2 VACPP compiler support from NSS
Status: RESOLVED FIXED
:
Product: NSS
Classification: Components
Component: Build (show other bugs)
: 3.11
: x86 OS/2
: P3 normal (vote)
: 3.12
Assigned To: Julien Pierre
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-16 11:27 PST by Mike Kaply [:mkaply]
Modified: 2007-09-13 02:16 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Full diff (11.70 KB, patch)
2006-03-16 11:28 PST, Mike Kaply [:mkaply]
julien.pierre: review+
Details | Diff | Splinter Review
Get mpi/Makefile.os2 working (17.48 KB, patch)
2007-06-02 03:38 PDT, Peter Weilbacher
julien.pierre: review-
Details | Diff | Splinter Review
Full VACPP removal diff, updated (16.76 KB, patch)
2007-06-02 03:47 PDT, Peter Weilbacher
mozilla: review+
julien.pierre: superreview+
Details | Diff | Splinter Review

Description Mike Kaply [:mkaply] 2006-03-16 11:27:59 PST
This bug is to remove VACPP support from NSS.
Comment 1 Mike Kaply [:mkaply] 2006-03-16 11:28:25 PST
Created attachment 215308 [details] [diff] [review]
Full diff
Comment 2 Mike Kaply [:mkaply] 2006-03-16 13:51:41 PST
Julien,

any idea if this file gets used?

http://lxr.mozilla.org/seamonkey/source/security/nss/lib/freebl/mpi/Makefile.os2

I couldn't find reference to it in any other makefile.
Comment 3 Julien Pierre 2006-03-16 14:13:40 PST
Mike,

This is used to build the MPI bignum library standalone, independently of the rest of the mozilla/NSS/NSPR build systems . The makefile builds a static library and a bunch of test programs using it. Only NSS developers use it in order to debug problems with the bignum library, or to test the library when changes to the code are made . It would be useful to keep it building or make it build if it doesn't currently work.
Comment 4 Peter Weilbacher 2007-06-02 03:38:33 PDT
Created attachment 266999 [details] [diff] [review]
Get mpi/Makefile.os2 working

OK, I have tried to get Makefile.os2 working with GCC. The OS/2 Toolkit is a prerequisite so alp.exe can continue to be used. But I couldn't get the existing mpi_x86 assembly files working, neither with alp nor with gcc/gas, so this would need to get mpi_x86.asm back (as included here). Why was the mpi_mips.s file includes in the OS/2 Makefile before?

The tools programs that I tried all run but I have no idea how to use them. mpi-test.exe also runs and doesn't return errors but also doesn't output anything for the available tests that I tried.
Comment 5 Peter Weilbacher 2007-06-02 03:47:57 PDT
Created attachment 267000 [details] [diff] [review]
Full VACPP removal diff, updated

This just updates the previous full diff for bitrot, against NSS on Mozilla trunk. I have done some quick tests with a Firefox trunk build and this patch and everything seems to work fine. Carrying over Julien's earlier r+.

I noticed some extra stuff that is about IBMCPP and EMX in dbm/src/dirent.[hc] but I don't think we have to do anything about that.

As I can probably only check in part of the patch I would appreciate if somebody else could just take care of that for everything. Julien perhaps? :-)
Comment 6 Julien Pierre 2007-06-05 17:29:20 PDT
Peter, the Makefile.os2 is only used internally by NSS developers for unit tests. It is not used in the mozilla build or even the NSS build. The mpi_mips.s was probably an error. I guess I really need to boot one of my boxes to OS/2 to check this out.
Comment 7 Julien Pierre 2007-06-07 19:19:55 PDT
Comment on attachment 266999 [details] [diff] [review]
Get mpi/Makefile.os2 working

The fact that there was a MIPS assembly file in the OS/2 Makefile means this Makefile never got used.  If any NSS developer ever ran this on OS/2 it would have been me, but I didn't run into the problem. Let's not patch this file and confuse people into thinking that this is actually useful and getting maintained. I suggested simply removing the Makefile.os2 from the tree. See bugzilla 383683 for an RFE to convert the mpi test suite to coreconf .
Comment 8 Julien Pierre 2007-06-07 19:20:35 PDT
Comment on attachment 266999 [details] [diff] [review]
Get mpi/Makefile.os2 working

r- based on comments above. This file should just be removed.
Comment 9 Peter Weilbacher 2007-09-10 14:32:59 PDT
Can someone please check in the patch from attachment 267000 [details] [diff] [review]? NSS checkin privileges are needed for at least some of the files. I think this should go onto NSS trunk and probably also whatever the branch for 3.12 is called.
Comment 10 Nelson Bolyard (seldom reads bugmail) 2007-09-10 14:40:57 PDT
Presently, the branch for 3.12 is called the trunk.  :)
I suggest you assign this to Julien.
Comment 11 Peter Weilbacher 2007-09-10 14:51:16 PDT
OK. :-)
Comment 12 Julien Pierre 2007-09-11 15:41:29 PDT
I checked this patch in on the trunk (NSS 3.12).
There was one very slight merge conflict in cmd/platlibs.mk which I resolved manually.

Checking in security/coreconf/OS2.mk;
/cvsroot/mozilla/security/coreconf/OS2.mk,v  <--  OS2.mk
new revision: 1.27; previous revision: 1.26
done
Checking in security/coreconf/rules.mk;
/cvsroot/mozilla/security/coreconf/rules.mk,v  <--  rules.mk
new revision: 1.76; previous revision: 1.75
done
Checking in security/nss/cmd/platlibs.mk;
/cvsroot/mozilla/security/nss/cmd/platlibs.mk,v  <--  platlibs.mk
new revision: 1.54; previous revision: 1.53
done
Checking in security/nss/cmd/dbtest/Makefile;
/cvsroot/mozilla/security/nss/cmd/dbtest/Makefile,v  <--  Makefile
new revision: 1.7; previous revision: 1.6
done
Checking in security/nss/cmd/lib/secpwd.c;
/cvsroot/mozilla/security/nss/cmd/lib/secpwd.c,v  <--  secpwd.c
new revision: 1.15; previous revision: 1.14
done
Checking in security/nss/cmd/selfserv/selfserv.c;
/cvsroot/mozilla/security/nss/cmd/selfserv/selfserv.c,v  <--  selfserv.c
new revision: 1.81; previous revision: 1.80
done
Checking in security/nss/lib/freebl/Makefile;
/cvsroot/mozilla/security/nss/lib/freebl/Makefile,v  <--  Makefile
new revision: 1.90; previous revision: 1.89
done
Checking in security/nss/lib/pk11wrap/Makefile;
/cvsroot/mozilla/security/nss/lib/pk11wrap/Makefile,v  <--  Makefile
new revision: 1.8; previous revision: 1.7
done
Checking in security/nss/lib/ssl/sslimpl.h;
/cvsroot/mozilla/security/nss/lib/ssl/sslimpl.h,v  <--  sslimpl.h
new revision: 1.61; previous revision: 1.60
done
Checking in security/nss/lib/ssl/sslsnce.c;
/cvsroot/mozilla/security/nss/lib/ssl/sslsnce.c,v  <--  sslsnce.c
new revision: 1.41; previous revision: 1.40
done
Comment 13 Peter Weilbacher 2007-09-13 02:16:43 PDT
Great, thanks Julien.

Note You need to log in before you can comment on or make changes to this bug.