Differing behavior with file:// url on same and different host

RESOLVED DUPLICATE of bug 122022

Status

()

Firefox
File Handling
--
minor
RESOLVED DUPLICATE of bug 122022
12 years ago
12 years ago

People

(Reporter: Fred Muhlenberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Deploying a WAR file to a JBoss app server
A sttic web page contains the following link:

<a href="file://///serverA/c$/downloads/TortoiseSVN-1.2.0.zip">Tortise</a>

When I access this page through the app server running on host serverA
and click on the link, nothing happens.  I must right click the link 
and choose Save Link As... to save the file.

If I bring up the identical page running on an app server of another host,
say serverB, selecting the link works as expected, displaying Microsoft's
Opening dialog.


Reproducible: Always

Steps to Reproduce:
1.Create a web page with the a link to a local file on Server A.  See details for sample link.
2. Deploy the web page to the app server running on Server A (I suppose a web server would work too)
3. Run your browser on Client B, display web page from Server A.
4. Click on link.  Nothing happens

Part 2
5. Deploy the web page to the app server running on Server C (I suppose a web server would work too)
6. Run your browser on Client B, display web page from Server C.
7. Click on link.
8. Opening dialog appears.

Actual Results:  
When the web page link points to a file that resides on the server's disks, nothing happens when clicking on the link .  If the web page link points to a file that resides on a different server's disks, an opening dialog is displayed.

Expected Results:  
I expected an opening dialog to be displayed in both cases.

The trivial work-around is to right-click and chose the Save Link As... menu option.
How do you access the server html page ?
With file:// in both cases or with http:// ?
(Reporter)

Comment 2

12 years ago
The server page was accessed using http://.  Then I would click on the link that confined the file:// uri.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> The server page was accessed using http://.  Then I would click on the link
> that confined the file:// uri.
> 
spelling correction: contained the file:// uri.

*** This bug has been marked as a duplicate of 122022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.