history button dropdowns should have configurable number of entries

RESOLVED DUPLICATE of bug 287277

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 287277
12 years ago
10 years ago

People

(Reporter: Marc Bejarano, Unassigned)

Tracking

1.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

currentyly, users are stuck with a maximum of 15 entries in their history dropdown lists when they click the forward or back buttons.  this should be configurable with a pref.  it looks like this might be hardcoded as MAX_HISTORY_MENU_ITEMS at either http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.js#64 or  http://lxr.mozilla.org/mozilla/source/xpfe/browser/resources/content/sessionHistoryUI.js#41

Reproducible: Always

Steps to Reproduce:
Why should it be configurable?  What would that add to the product?
Not asked to me :) but the advantage of the Go-menu is that it displays also the history of the previous session.
After closing a tab or after a browser restart the session history under the Back and Forward button is gone but it is still displayed in the Go-menu.
So after reading the news on your homepage after a restart, you go back to the things you did before closing the browser.
Even a history sidebar can't replace this function.


That's totally unrelated to this bug.

Comment 4

12 years ago
Duplicate of/related to bug 287277/Suite bug 62010?
(Reporter)

Comment 5

12 years ago
yep.. dupe of 287277.  i seem to be really bad at searching for existing bugs before reporting them :(

*** This bug has been marked as a duplicate of 287277 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.