Restricted to single screen on multi-screen X configuration.

RESOLVED DUPLICATE of bug 319965

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 319965
12 years ago
11 years ago

People

(Reporter: Nick Bowler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060228 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060228 Firefox/1.5.0.1

When running a multi-screen X configuration, loading firefox on one of the screens 'locks' firefox to that screen - it becomes impossible to open any browser windows on other screens.  Running firefox on another screen simply opens a new window on the screen that firefox is 'locked' to.

It would be also nice if 'new window' could be extended to allow opening on any X screen, or the ability to send a window to another screen (as seen in GIMP)

Reproducible: Always

Steps to Reproduce:
1. Configure X to use 2 screens.
2. Open firefox on :0.1
3. Try to open firefox on :0.0

Actual Results:  
Firefox opens a new window on the screen it is already running on.

Expected Results:  
Firefox opens a new window on the screen defined in the DISPLAY environment variable.
How are you doing multi-head graphics? Are you using Xinerama?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> How are you doing multi-head graphics? Are you using Xinerama?
> 

Using multiple non-xinerama screens (i.e. can't normally move windows across - see gimp as a worthy exception)
If you run Firefox from the console when you try this, are any messages printed?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> If you run Firefox from the console when you try this, are any messages
> printed?
> 

Yes:

nick@artemis ~ $ firefox
/usr/lib64/mozilla-firefox/mozilla-xremote-client: Error: Failed to find a running server.

Only displays when running on a different screen from which firefox is running.  The command still opens a new window on the other screen though.
Can you try running the standard diagnostic? (http://kb.mozillazine.org/Standard_diagnostic_(Firefox))

Comment 6

11 years ago
I experience the same behavior.  I don't think this is something that
broke; I think it's been broken from the start.  I've been using
Firefox/Mozilla/Netscape/Mosaic since 1996, and I'm pretty sure the only
way to to open windows on multiple screens (truly separate screens, like
:0.0 and :0.1, not xinerama screens, which are all :0.0) has always
been to run a separate browser process on each screen.  A long time ago
(early versions of Netscape?) it was possible to run multiple browser
processes from the same config dir (though maybe that was asking for
trouble), but now you have to use a different profile for each process
(and hence for each screen).  It sure would be nice to be able to run
one process that could open windows on multiple screens.

Comment 7

11 years ago
I am also experiencing this behavior in both Firefox 1.5.* and Firefox 2b1 . It would be really nice if it could run using the same process. 

Comment 8

11 years ago
dup of bug 319965?

Comment 9

11 years ago
apparently a dup. Thanks for pointing out.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 319965
You need to log in before you can comment on or make changes to this bug.