Links to shared UNC files like file://///winhost/file don't work if the page containing them opened from http://

RESOLVED DUPLICATE of bug 122022

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 122022
12 years ago
12 years ago

People

(Reporter: Arkady Sherman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060206 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060206 SeaMonkey/1.5a

Links to shared UNC files like file://///winhost/badlink don't work if the page containing them opened from http://foohost/badfile resource. That is nothing hapened neither when clicking to the link nor when trying "Open link in new window" or tab. But if the same page is opened from local host, for example from file:///C:/temp/badfile, everything becomes alright.

Reproducible: Always

Steps to Reproduce:
1. Create a file with links like <a href="file://///winhost/badlink">badlink</a>
2. Put it somewere in http://
3. Try to open the links contained in badlink which is opened from http://
4. Save the page to local disk and open it from where
5. The bad links will become working 
Actual Results:  
Links like file://///winhost/badlink don't work when being contained in a page opened from http:// resource

Expected Results:  
They should work

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 122022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.