Permission denied to get property HTMLDivElement.parentNode

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: tehdnite, Unassigned)

Tracking

(Depends on: 1 bug, {testcase})

Trunk
x86
Windows XP
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The above error happens when I mouseover the input box and leave it on the test page. I made this page out of a larger site I'm working on to demonstrate the error, but in this page I removed the mouseout checking to simplify the page and found that the error is actually triggered when the mouse leaves the text box and not when you enter it. Very weird 'bug'.

Reproducible: Always

Steps to Reproduce:
1. Mouse over the outer div will trigger the mouseover
2. enter the text box with the mouse
3. leave the text box with the mouse
4. error is produced.

Actual Results:  
Everything seems to work normally as far as the site is concerned, but the following error is produced anyways...

[Exception... "'Permission denied to get property HTMLDivElement.parentNode' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

Expected Results:  
Same results, minus the error message.

I can't think of anything else that would be relevant to this bug

Comment 1

13 years ago
Maybe related to Core bug 214340 -> Core bug 208427?
Assignee: nobody → events
Component: General → DOM: Events
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
It's very possible it's related to Core bug 208427 .. Sounds like the same general outcome..

Comment 3

12 years ago
I have been getting this same error when clicking inside of a input type="text" box.  

Web searches on the error only return instances of other people having the same issue.  

The common suggestion of setting autocomplete="off" to the textbox or whole form does not work.
The page can not be found anymore, could you perhaps attach the testcase to the bug?
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> The page can not be found anymore, could you perhaps attach the testcase to the
> bug?
> 

I apologize.. Some domain name changes.. I re-uploaded the test page to http://www.dnite.org/test.html
Created attachment 232010 [details]
testcase

Thanks, I'm attaching the testcase to the bug, so it won't get lost.
Depends on: 208427
Keywords: testcase

Comment 7

10 years ago
I just tested this in FF3 and did not see the issue.  So it looks like it got fixed.

Updated

10 years ago
Depends on: 434522
Assignee: events → nobody
QA Contact: ian → events
Don't see anything in the error console with the attached test case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.