Crash when quitting browser while movie is playing.

VERIFIED FIXED in M18

Status

()

P3
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: jelwell, Assigned: serhunt)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3+][PDTP3], URL)

(Reporter)

Description

19 years ago
Steps to reproduce:
0)Open a new Browser window.
1)Load Url.
2)Click where it says, to start the movie.
3)Let is load a little (if you're on a slow connection)
4)Hit play.
5)Close the browser. Using the "X" widget on the top right. or ALT-F4 was tested.
*crash*

This crash isn't so bad when you're just exiting Mozilla anyways - but when you
close a window with a quicktime movie playing and all your other windows crash;
that's bad.

I tested this on winNT 2000032308. My Quicktime Readme says it's 4.1.

Comment 1

19 years ago
I see this.

Comment 2

19 years ago
Top priority for m16
Severity: critical → blocker
Target Milestone: --- → M16
(Assignee)

Comment 3

19 years ago
Updating URL

Comment 4

19 years ago
Adding crash keyword.
Keywords: crash
Keywords: quicktime
Nominating nsbeta2. Quicktime crasher. Quicktime is on beta2 criteria list.
Keywords: nsbeta2

Comment 6

19 years ago
[nsbeta2+] Need to at least block the crash for PR2.
Whiteboard: [nsbeta2+]

Comment 7

19 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 8

19 years ago
Reassigning as per agreement.
Assignee: av → amusil
Status: ASSIGNED → NEW

Comment 9

19 years ago
Looks like a crash in the dom event handler.

Stack:

nsGenericElement::HandleDOMEvent(nsIPresContext * 0x029d2470, nsEvent * 
0x0012e570, nsIDOMEvent * * 0x0012df9c, unsigned int 0x00000001, nsEventStatus * 
0x0012e594) line 1369 + 33 bytes
nsGenericHTMLElement::HandleDOMEventForAnchors(nsIContent * 0x04177afc, 
nsIPresContext * 0x029d2470, nsEvent * 0x0012e570, nsIDOMEvent * * 0x00000000, 
unsigned int 0x00000001, nsEventStatus * 0x0012e594) line 1097 + 31 bytes
nsHTMLAnchorElement::HandleDOMEvent(nsHTMLAnchorElement * const 0x04177afc, 
nsIPresContext * 0x029d2470, nsEvent * 0x0012e570, nsIDOMEvent * * 0x00000000, 
unsigned int 0x00000001, nsEventStatus * 0x0012e594) line 413
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x071c79c8, 
nsIPresContext * 0x041626e0, nsEvent * 0x0012e7e8, nsIFrame * 0x0329fc68, 
nsEventStatus * 0x0012e750, nsIView * 0x041621f0) line 356
PresShell::HandleEventInternal(nsEvent * 0x0012e7e8, nsIView * 0x041621f0, 
nsEventStatus * 0x0012e750) line 3896 + 43 bytes
PresShell::HandleEvent(PresShell * const 0x041608a4, nsIView * 0x041621f0, 
nsGUIEvent * 0x0012e7e8, nsEventStatus * 0x0012e750, int & 0x00000001) line 3837 
+ 23 bytes
nsView::HandleEvent(nsView * const 0x041621f0, nsGUIEvent * 0x0012e7e8, unsigned 
int 0x0000001c, nsEventStatus * 0x0012e750, int & 0x00000001) line 782
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x041623d0, nsGUIEvent * 
0x0012e7e8, nsEventStatus * 0x0012e750) line 1389
HandleEvent(nsGUIEvent * 0x0012e7e8) line 69
nsWindow::DispatchEvent(nsWindow * const 0x041620c4, nsGUIEvent * 0x0012e7e8, 
nsEventStatus & nsEventStatus_eIgnore) line 560 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012e7e8) line 581
nsWindow::DispatchFocus(unsigned int 0x00000069) line 3825 + 15 bytes
nsWindow::ProcessMessage(unsigned int 0x00000007, unsigned int 0x01d10508, long 
0x00000000, long * 0x0012eb2c) line 2887 + 19 bytes
nsWindow::WindowProc(HWND__ * 0x00910456, unsigned int 0x00000007, unsigned int 
0x01d10508, long 0x00000000) line 829 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
GlobalWindowImpl::Focus(GlobalWindowImpl * const 0x04184354) line 1365 + 23 
bytes
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012edac) line 547
nsWindow::DispatchEvent(nsWindow * const 0x04184d44, nsGUIEvent * 0x0012edac, 
nsEventStatus & nsEventStatus_eIgnore) line 560 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012edac) line 581
nsWindow::DispatchFocus(unsigned int 0x00000069) line 3825 + 15 bytes
nsWindow::ProcessMessage(unsigned int 0x00000007, unsigned int 0x21450476, long 
0x00000000, long * 0x0012f0f0) line 2887 + 19 bytes
nsWindow::WindowProc(HWND__ * 0x01d10508, unsigned int 0x00000007, unsigned int 
0x21450476, long 0x00000000) line 829 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e718d2()
nsWindow::DefaultWindowProc(HWND__ * 0x01d10508, unsigned int 0x00000006, 
unsigned int 0x00000001, long 0x01dd04fe) line 856
USER32! 77e727fe()
USER32! 77e72889()
nsWindow::WindowProc(HWND__ * 0x01d10508, unsigned int 0x00000006, unsigned int 
0x00000001, long 0x01dd04fe) line 836 + 31 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
nsXULWindow::SetVisibility(nsXULWindow * const 0x04184f24, int 0x00000001) line 
514
nsXULWindow::OnChromeLoaded() line 652
nsWebShellWindow::OnEndDocumentLoad(nsWebShellWindow * const 0x04184f84, 
nsIDocumentLoader * 0x04184850, nsIChannel * 0x04161f70, unsigned int 
0x00000000) line 1278
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x04184a98, nsIDocumentLoader * 
0x04184850, nsIChannel * 0x04161f70, unsigned int 0x00000000) line 1191
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x04184850, nsIChannel 
* 0x04161f70, unsigned int 0x00000000) line 809
nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int 0x00000000) line 615
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x04184854, nsIChannel * 
0x07208a00, nsISupports * 0x00000000, unsigned int 0x00000000, const unsigned 
short * 0x00000000) line 543
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x041847f0, nsIChannel * 
0x07208a00, nsISupports * 0x00000000, unsigned int 0x00000000, const unsigned 
short * 0x00000000) line 544 + 39 bytes
nsFileChannel::OnStopRequest(nsFileChannel * const 0x07208a08, nsIChannel * 
0x07208de0, nsISupports * 0x00000000, unsigned int 0x00000000, const unsigned 
short * 0x00000000) line 637
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x0720fd70) line 
302
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x0720f510) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x0720f510) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x014a6320) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00c00540, unsigned int 0x0000c187, unsigned int 
0x00000000, long 0x014a6320) line 1032 + 9 bytes
USER32! 77e71820()
014a6320()

I'm leaving on Thurs, so reassigning to saari based on cvs blame.  Also cc'ing 
jst.
Assignee: amusil → saari
Target Milestone: M16 → M18
Bug 27660, bug 43643, and bug 44175 have similar stack traces.

Comment 11

19 years ago
Well, the crash is in the ns4xPluginStreamListener. Who's going to be handling 
this now?
(Assignee)

Comment 12

19 years ago
How do you see that? On my machine it does not give any usable stack trace.

Comment 13

19 years ago
Moving from [nsbeta2+] to [nsbeta2-] per todays PDT XP Toolkit Beta2 Review mtg.
Whiteboard: [nsbeta2+] → [nsbeta2-]

Comment 14

19 years ago
But what should be beta+ is the movie being half clipped out due to a 
mispositioning.
(Reporter)

Comment 15

19 years ago
saari: did you file a bug on the clipping/mispositioning? I don't see that in
2000070713 win comm build with quicktime 4.0.

Comment 16

19 years ago
I just filed that as 44840

Comment 17

19 years ago
reassigning to av. Andrei, isn't this more your area?
Assignee: saari → av
Nom. nsbeta3 as crasher.
Keywords: nsbeta3

Comment 19

19 years ago
av, please either accept this bug or reassign it. Also, if you have any more 
information on it please note that so we can decide if it should be approved for 
nsbeta3 - thanks.
(Assignee)

Comment 20

19 years ago
According to what I see it crashes inside QuickTime on shutdown. I will 
definitely need help to fix this one, likely we don't have much to do without 
Apple people.

I can add a couple of try/catch ornamentations which will at least prevent it 
from crashing.
Status: NEW → ASSIGNED

Updated

19 years ago
Whiteboard: [nsbeta2-] → [nsbeta2-] [nsbeta3+]

Updated

19 years ago
Priority: P3 → P1

Comment 21

19 years ago
Can release note not to do this.  Moving to P3.  Adding [PDTP3]
Keywords: relnote3, relnoteRTM
Priority: P1 → P3
Whiteboard: [nsbeta2-] [nsbeta3+] → [nsbeta2-][nsbeta3+][PDTP3]
(Assignee)

Comment 22

19 years ago
I have something to check in which prevents this. The thing is it also crashes 
time to time when you just leave the page, so I would still like to get the fix 
in.
(Assignee)

Updated

19 years ago
Whiteboard: [nsbeta2-][nsbeta3+][PDTP3] → [nsbeta2-][nsbeta3+][PDTP3][HAVE FIX]
(Assignee)

Comment 23

19 years ago
I checked in the proposed fix and will mark it fixed shortly.
Whiteboard: [nsbeta2-][nsbeta3+][PDTP3][HAVE FIX] → [nsbeta2-][nsbeta3+][PDTP3][FIX IS IN]
(Assignee)

Comment 24

19 years ago
Marking. There is unexpected artifact showing up on recent builds, flying dutch, 
an unintended window. Shrirang, if you see this please file a new bug on it.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2-][nsbeta3+][PDTP3][FIX IS IN] → [nsbeta2-][nsbeta3+][PDTP3]

Comment 25

19 years ago
verified this is fixed on win br build 2000092908. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.