location dialog presence causes keyboard input mishandling in main-window text box

VERIFIED FIXED in M15

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: jon rekai, Assigned: Dan M)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
steps to reproduce:
1.  Choose File | Open Web Location
2.  Give focus to address bar text area.
3.  Hit ctrl-c.

Comments:
Occurs in window/instance from which Open Web Location was raised.  Other
mozilla instances are not affected.
Does not occur when ctrl-l is used to open a location.
It is not necessary to browse to any particular location.  about:blank is fine.
Reproducibility: always.

Comment 1

18 years ago
I cannot reproduce this with either 2000032306 win98 (beta1), or
2000032309 win98 (trunk). Can you note what build you are using, 
confirm that this was on win95, and elaborate on the steps to reproduce. 
Thanks.
(Reporter)

Comment 2

18 years ago
Does not occur with find, about dialogs.
Build ID: 2000032308
Platform: Win95 OSR2
Processor: PentiumII

Earlier build (a 20000322xx) exhibited the same.  I just ctrl-n opened a new
window, clicked File | Open Web Location.  Click back on main/parent window
(sorry, that part is significant) address bar, hit ctrl-c, and out it goes.
Other windows, like the one i'm typing in, are not affected.  I'll make a point
of trying it on NT4 tomorrow.


(Reporter)

Comment 3

18 years ago
reproduced on nt4 sp3 builds 2000332210 and 2000032308.
(Reporter)

Comment 4

18 years ago
reproduced with 2000032416 w95.
(Reporter)

Comment 5

18 years ago
reproducible NT4 SP3 build 2000032416.  will continue checking daily builds but
refrain from posting comments daily until further direction receiver or behavior
can no longer be reproduced.

Steps to reproduce:
0. Get a mozilla instance- fresh start or a new window.
1. File | Open Web Location (mouse it or alt-f-l).
2. Give focus to main-window navbar.
3. Ctrl-C.

Additional information:
--cannot reproduce after mousing over main-window menu bar.

(Reporter)

Comment 6

18 years ago
Revised steps to reproduce (2000032409, 2000032416, w95- will check NT4 later)
0. Get a mozilla instance- fresh start or a new window.
1. File | Open Web Location (mouse it or alt-f-l).
2. Leave dialog up, go back to the main-window (give it focus).
3. Go do anything but mouse over the main menu.
-. optional: If your sidebar is open, go doubleclick a bookmark that'll take you
to a page with an input text box or textarea.
4. Give focus to main-window navbar, sidebar-search-text, or a text box or
textarea on the web page.  (carat should be flashing there.)
5. Ctrl-C.

Niether a popup (html) window (aol.com/) nor a javascript alert prevented ctrl-c
from killing the instance.
(Reporter)

Comment 7

18 years ago
w95, build 2000032409, 2000032416

Looks like having the location dialog up causes keyboard input in main-window
textboxes/areas to be mishandled.

To kill the application instance:
1. Ideally, have several main-window instances open; page content doesn't seem
significant.
2. Go to home.netscape.com or any page that has a textbox/area.
2. File | Open Web Location (mouse or alt-f-l).
3. Click the "Weather Search - Enter city..." textbox in main-window or other
available textbox/area in main-window, including nav-bar or sidebar-search-text.
4. Depress 'q'

Related:
Follow steps 1 through 3 above.
4. File | Open Web Location (mouse or alt-f-l) to raise the location dialog.
5. Type 'n'.  You should have a new main-window instance.  Do whatever you want
with it.
6. Back in the original main-window, dismiss and then raise the location dialog
again.
7. Click the textbox in main-window.
8. Type one of the following chars for the desired result:
   c       death to the main-window instance
   d       Composer with page in edit mode
   e       edit context menu
   l       another location dialog
   o       open dialog
   s       save dialog
   i, p    Mail!  I would have expected 'm' to do that
and, 'q' kills the app.

If the app wasn't killed, dismiss the location dialog and raise again.  Go back
and try another char.

Note:
Other application instances are not affected by the application instance being
killed.
[ctrl-] is optional.
Text may be present in the main-window navbar or document textbox/area and may
be selected when the [ctrl]-c is issued.
The carat position in the textbox/area is not significant.
Summary: ctrl-c kills instance → [ctrl-]c kills instance, 'q' kills application
(Reporter)

Comment 8

18 years ago
reproducible nt4 sp3 and w95 builds 2000032409 and 2000032416.  Also
reproducible in composer- both OSs, both builds above- edit a page with a
textbox and follow steps for browser.  With location dialog raised, first
keystroke in a textbox/area in parent main-window is treated as an
accelerator(accesskey) for main-menubar.
Summary: [ctrl-]c kills instance, 'q' kills application → location dialog presence causes keyboard input mishandling in main-window text box

Comment 9

18 years ago
reassigning to danm for triage, cc saari.
Assignee: trudelle → danm
(Assignee)

Comment 10

18 years ago
The Open Location Dialog is modal, and it's a bug that you can even give focus to 
its parent window. Why doing so has such neat repercussions is something of a 
mystery. (Well, it seems the File Menu in the parent window can't release 
keyboard focus while basically still processing the "open location dialog" 
command). That's probably excuseable behaviour. So rather than solving it, I've 
nipped it instead by reinstating the modal window's modal behaviour (see bug 
30633.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Updated

18 years ago
Target Milestone: --- → M15
(Assignee)

Comment 11

18 years ago
(PS: thanks, jonrekai, for all the analysis. It made the problem much more 
clear.)
(Reporter)

Comment 12

18 years ago
glad i could help make an issue readily identifyable-  you're the ones who
deserve the thanks, though.  :)

Comment 13

17 years ago
Works for Me
Platform: PC
OS: Windows 98
Build # 2000100508

Marking as Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.