Mozilla CTD and reports errr when dowloading or using most tools in the tool menu [@ nsMimeType::GetDescription]

RESOLVED DUPLICATE of bug 328113

Status

()

Firefox
Toolbars and Customization
--
critical
RESOLVED DUPLICATE of bug 328113
12 years ago
7 years ago

People

(Reporter: Peter, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Starting today (3/22) when I try to download anything or "dowloads" or "options" from the tool menu Mozilla will crash and send an error report.  I tried uninstalling and reinstalling (multiple times), using system restore, scanning for virusses and running disk check, and the problem persistes.

Reproducible: Always

Steps to Reproduce:
1.  open Mozilla
2.  try to download
3.  or try to use tools or options form tool menu

Actual Results:  
Mozilla crashed to desktop and sends an error report to microsoft (I'm sure that'll help).

Expected Results:  
Downloaded or opened the tool
Could you please install Talkback (http://kb.mozillazine.org/Talkback), get an ID for the crash and paste it here?
Keywords: crash
(Reporter)

Comment 2

12 years ago
Talkback crash ID:  TB16712358X
Stack Signature	 nsMimeType::GetDescription d1282c50
Product ID	Firefox15
Build ID	2006011112
Trigger Time	2006-03-22 15:07:46.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (0021451d)
URL visited	
User Comments	
Since Last Crash	8 sec
Total Uptime	8 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/base/nsMimeTypeArray.cpp, line 269
Stack Trace 	
nsMimeType::GetDescription  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/base/nsMimeTypeArray.cpp, line 269]
nsDownloadManager::~nsDownloadManager  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/toolkit/components/downloads/src/nsDownloadManager.cpp, line 147]
nsComponentManagerImpl::GetService  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpcom/components/nsComponentManager.cpp, line 2105]
nsJSCID::GetService  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcjsid.cpp, line 899]
XPTC_InvokeByIndex  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2152]
XPC_WN_CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1444]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1177]
js_Interpret  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 3551]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1197]
js_InternalInvoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1274]
JS_CallFunctionValue  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsapi.c, line 4158]
nsJSContext::CallEventHandler  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1411]
nsJSEventListener::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/events/nsJSEventListener.cpp, line 195]
nsEventListenerManager::HandleEventSubType  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/content/events/src/nsEventListenerManager.cpp, line 1685]
nsEventListenerManager::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/content/events/src/nsEventListenerManager.cpp, line 1786]
nsGlobalWindow::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp, line 1557]
DocumentViewerImpl::LoadComplete  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsDocumentViewer.cpp, line 1012]
nsDocShell::EndPageLoad  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp, line 4753]
nsWebShell::EndPageLoad  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/docshell/base/nsWebShell.cpp, line 664]
nsDocShell::OnStateChange  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp, line 4679]
nsDocLoader::FireOnStateChange  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/uriloader/base/nsDocLoader.cpp, line 1210]
nsDocLoader::doStopDocumentLoad  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/uriloader/base/nsDocLoader.cpp, line 844]
nsDocLoader::OnStopRequest  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/uriloader/base/nsDocLoader.cpp, line 665]
nsLoadGroup::RemoveRequest  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsLoadGroup.cpp, line 732]
imgRequestProxy::RemoveFromLoadGroup  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/modules/libpr0n/src/imgRequestProxy.cpp, line 178]
imgRequestProxy::OnStopRequest  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/modules/libpr0n/src/imgRequestProxy.cpp, line 510]
imgRequest::OnStopRequest  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/modules/libpr0n/src/imgRequest.cpp, line 754]


Deleting downloads.rdf from your profile (http://kb.mozillazine.org/Profile) or starting over with a new profile should get things back to normal. If you need further assistance, please see the MozillaZine forums (http://forums.mozillazine.org).

*** This bug has been marked as a duplicate of 328113 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Summary: Mozilla CTD and reports errr when dowloading or using most tools in the tool menu → Mozilla CTD and reports errr when dowloading or using most tools in the tool menu [@ nsMimeType::GetDescription]
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsMimeType::GetDescription]
You need to log in before you can comment on or make changes to this bug.