Firefox ignores @page directives when printing

RESOLVED DUPLICATE of bug 115199

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 115199
12 years ago
12 years ago

People

(Reporter: Matthew Johnson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060315 Debian/1.5.dfsg+1.5.0.1-3bpo1 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060315 Debian/1.5.dfsg+1.5.0.1-3bpo1 Firefox/1.5.0.1

When printing or using print preview firefox ignores the page and margin directives given in the CSS on that page. The example test case should set the page size to A5 landscape and custom margins. Firefox does not do this.

Reproducible: Always

Steps to Reproduce:
1. Visit any webpage with @page directives
2. print preview

Actual Results:  
Uses default/latest printing settings

Expected Results:  
should take the page size, orientation and margins from CSS

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 115199 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.