If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[BeOS] Build Broken in nsAnnotationService.cpp

RESOLVED FIXED in Firefox 2 alpha2

Status

()

Firefox
Bookmarks & History
P4
critical
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Doug Shelton, Unassigned)

Tracking

({fixed1.8.1})

Trunk
Firefox 2 alpha2
x86
BeOS
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20060318 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20060318 Firefox/1.6a1

Bustage occured sometime after 2006-03-18.

nsAnnotationService.cpp
c++ -o nsAnnotationService.o -c  -DMOZILLA_INTERNAL_API -DOSTYPE=\"BeOS6.0.1\" -DOSARCH=\"BeOS\" -DBUILD_ID=0000000000 -I/boot/home/develop/mozilla/browser/components/places/src/../../build -I../../../../dist/include/xpcom -I../../../../dist/include/string -I../../../../dist/include/history -I../../../../dist/include/docshell -I../../../../dist/include/rdf -I../../../../dist/include/dom -I../../../../dist/include/morkreader -I../../../../dist/include/pref -I../../../../dist/include/necko -I../../../../dist/include/intl -I../../../../dist/include/layout -I../../../../dist/include/locale -I../../../../dist/include/unicharutil -I../../../../dist/include/autocomplete -I../../../../dist/include/storage -I../../../../dist/include/uconv -I../../../../dist/include/htmlparser -I../../../../dist/include/content -I../../../../dist/include/txmgr -I../../../../dist/include/xmlextras -I../../../../dist/include/caps -I../../../../dist/include/xpconnect -I../../../../dist/include/js -I../../../../dist/include/nkcache -I../../../../dist/include/widget -I../../../../dist/include   -I../../../../dist/include/places -I../../../../dist/include/nspr       -fPIC   -frtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-multichar -Wno-long-long -pedantic -pipe  -DNDEBUG -DTRIMMED -O3 -march=i686 -mcpu=i686 -frerun-cse-after-loop -frerun-loop-opt   -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -Wp,-MD,.deps/nsAnnotationService.pp /boot/home/develop/mozilla/browser/components/places/src/nsAnnotationService.cpp
/boot/home/develop/mozilla/opt-Zeta/dist/include/xpcom/nsAutoPtr.h: In method `nsRefPtr<nsNavHistoryResult>::~nsRefPtr()':
/boot/home/develop/mozilla/browser/components/places/src/nsNavHistoryResult.h:658:   instantiated from here
In file included from /boot/home/develop/mozilla/browser/components/places/src/nsNavHistory.h:76,
                 from /boot/home/develop/mozilla/browser/components/places/src/nsAnnotationService.cpp:41:
/boot/home/develop/mozilla/opt-Zeta/dist/include/xpcom/nsAutoPtr.h:956: invalid use of undefined type `class nsNavHistoryResult'
/boot/home/develop/mozilla/browser/components/places/src/nsNavHistoryResult.h:53: forward declaration of `class nsNavHistoryResult'
make[7]: *** [nsAnnotationService.o] Error 1
make[7]: Leaving directory `/boot/home/develop/mozilla/opt-Zeta/browser/components/places/src'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/boot/home/develop/mozilla/opt-Zeta/browser/components/places'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/boot/home/develop/mozilla/opt-Zeta/browser/components'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/boot/home/develop/mozilla/opt-Zeta/browser'
make[3]: *** [libs_tier_99] Error 2
make[3]: Leaving directory `/boot/home/develop/mozilla/opt-Zeta'
make[2]: *** [tier_99] Error 2
make[2]: Leaving directory `/boot/home/develop/mozilla/opt-Zeta'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/boot/home/develop/mozilla/opt-Zeta'
make: *** [build] Error 2
$    

Reproducible: Always
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

12 years ago
based on console output, this could be related to one of several changes committed to nsNavHistoryResult.cpp
(Reporter)

Updated

12 years ago
Summary: Build Broken in nsAnnotationService.cpp → [BeOS] Build Broken in nsAnnotationService.cpp

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
Created attachment 216256 [details] [diff] [review]
Removed forward ref of nsNavHistoryResult

Moved the nsNavHistoryResult class declaration so it doesn't need a forward ref.

Updated

12 years ago
Keywords: helpwanted
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Created an attachment (id=216256) [edit]
> Removed forward ref of nsNavHistoryResult
> 
> Moved the nsNavHistoryResult class declaration so it doesn't need a forward
> ref.
> 

Patch applied here and now able to build.  Looks like this fixes the bustage.  Thanks, tqh!

Comment 4

12 years ago
Who do I ask for review from on this bug?

Also need someone to commit on review.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> Who do I ask for review from on this bug?
> 
> Also need someone to commit on review.
> 
Other changes to this file were made by brettw@gmail.com.  I'd ask him for review.
(Reporter)

Updated

12 years ago
Blocks: 311302

Comment 6

12 years ago
Comment on attachment 216256 [details] [diff] [review]
Removed forward ref of nsNavHistoryResult

r?

(Also need someone to checkin on review)
Attachment #216256 - Flags: review?(brettw)
Priority: -- → P4
Target Milestone: --- → Firefox 2 alpha2

Comment 7

12 years ago
Comment on attachment 216256 [details] [diff] [review]
Removed forward ref of nsNavHistoryResult

I'll check it in shortly.
Attachment #216256 - Flags: review?(brettw) → review+

Comment 8

12 years ago
Checked in on branch and trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: helpwanted → fixed1.8.1
Resolution: --- → FIXED
(Reporter)

Comment 9

12 years ago
(In reply to comment #8)
> Checked in on branch and trunk
> 
Thank you, Brett!
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.