Closed Bug 331729 Opened 16 years ago Closed 16 years ago

[FIX]position: fixed elements are positioned relative to the page rather than the viewport

Categories

(Core :: Layout: Positioned, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9alpha1

People

(Reporter: bugzilla-mozilla-20000923, Assigned: bzbarsky)

References

()

Details

(Keywords: regression, testcase)

Attachments

(1 file)

This is the same as bug 268111. The testcase in that bug works as well as the one I wrote for this bug:
  http://silver.warwickcompsoc.co.uk/temp/pos_fixed_jump.html

(note: the server admins [not me] have fucked up the Apache config, so that 500s currently, but it will be fixed soon)

This bug applies to current trunk, but not Firefox 1.5.
This regressed between 2006-03-09-07 and 2006-03-10-13.  Bonsai range:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-03-09+07&maxdate=2006-03-10+13&cvsroot=%2Fcvsroot

And I'm seeing this on Linux too.

Looks like a regression from bug 328881 -- we were relying on scrolled frames being positioned at (0,0).
Blocks: 328881
OS: Windows Server 2003 → All
Hardware: PC → All
Attached patch FixSplinter Review
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #217121 - Flags: superreview?(roc)
Attachment #217121 - Flags: review?(roc)
Flags: blocking1.9a1+
Priority: -- → P2
Summary: position: fixed elements are positioned relative to the page rather than the viewport → [FIX]position: fixed elements are positioned relative to the page rather than the viewport
Target Milestone: --- → mozilla1.9alpha
Attachment #217121 - Flags: superreview?(roc)
Attachment #217121 - Flags: superreview+
Attachment #217121 - Flags: review?(roc)
Attachment #217121 - Flags: review+
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.