non-conventional time picker is difficult to use

VERIFIED DUPLICATE of bug 275253

Status

Calendar
General
--
enhancement
VERIFIED DUPLICATE of bug 275253
12 years ago
9 years ago

People

(Reporter: eva, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I find the grid time picker is awkward to use - plus, it always displays times in military time.  

Can you incorporate a more conventional time picker? 

Reproducible: Always
this issue was already on my list of upcoming tasks, so i'll take this one.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
reassigned.
Assignee: nobody → michael.buettner
Status: ASSIGNED → NEW

Comment 3

12 years ago
I'll add to this one in case the format changes completely. The current "unconventional" time picker is incompatible with at least three Thunderbird themes (Crossover, Crossover X, and Tiger Mail). The picker works but there is no user feedback (no highlighting of the hour or minute selection),. It just "hears" the click and changes when you close the picker. Weird.

Please test a theme or two with the new picker. :-)

I second the request for a more "standard" picker.
Christian, I hope you find some time for coming up with a proposal. If anybody else has ideas, feel free to throw them in here.
Assignee: michael.buettner → nobody
Component: Sunbird Only → General
OS: Windows XP → All
QA Contact: sunbird → general
Hardware: PC → All

Comment 5

9 years ago
I actually like the time picker shipped with Sunbird pretty much although I agree that there is room for improvement.

Here is my suggestion for improved interface. There is suggestion for military 
time as well as AM/PM: (Please do not pay attention to borders, fonts etc., these are just a quick mock-ups)

Military proposal:
http://img267.imageshack.us/img267/856/proposal-military-collapsed.png
http://img267.imageshack.us/img267/615/proposal-military-expanded.png

AM/PM proposal:
http://img267.imageshack.us/img267/9049/proposal-am-pm-collapsed.png
http://img267.imageshack.us/img267/5646/proposal-am-pm-expanded.png

For reference, compare with current interface (Sunbird 0.9 / Lightning 0.9):

http://img267.imageshack.us/img267/3901/current-time-picker-collapsed.png
http://img267.imageshack.us/img267/462/current-time-picker-expanded.png


Background for suggestion:
----
After plenty of searches, I still do not know what a "conventional" time picker looks like. In fact, there are at least a dozen of different time pickers out there, yet, there is apparently no accepted best practice. (No time picker has made me say wow!!)

In my opinion, the main problem with the current time picker shipped with Sunbird 0.9 is that the hours are displayed above the minutes. When I pick a time, I look towards the left half of the time picker to select an hour value, and I look towards the right half of the time picker to select the minutes. That's how you write time values – hours to the left, minutes to the right. Therefore I suggest rotating the view 90 degrees as shown in the screen shots.

Since I'm living in Denmark, I prefer military time rather than AM/PM display, but I guess that U.S. users will prefer the latter. So some setting to control time display may be appropriate.

Comment 6

9 years ago
duplicate of bug 275253 where there's more activity. Please also have a look at the suggestions in that bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 275253

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.