Mozilla products should check for updates, even if they can't install them

RESOLVED DUPLICATE of bug 318855

Status

()

RESOLVED DUPLICATE of bug 318855
13 years ago
10 years ago

People

(Reporter: usenet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPME])

(Reporter)

Description

13 years ago
At the moment, you can't check for updates if you are not in a position to install them. This is bad, because:
* careful users who have admin rights to boxes, but prudently do not run as administrator/root unless necessary, will not be alerted that updates are available, and won't install them unless they either check the website or run as root and run the autochecker
* users without admin rights will not be able to see that there are updates, and won't nag their system administrators until they install the update
(Reporter)

Comment 1

13 years ago
...and as a result, machines that should be patched will be left unpatched.

Solution: 
* make all versions of the software poll periodically, even if they do not have admin rights
* offer the option to turn this off at build or install time, for embedders and kiosk users, but make the default to leave it on

Updated

13 years ago
Whiteboard: [DUPME]

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 318855 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.