'All' vs. 'This occurrence' dialog not shown when deleting recurring event via menu/toolbar

VERIFIED WORKSFORME

Status

Calendar
Sunbird Only
VERIFIED WORKSFORME
12 years ago
11 years ago

People

(Reporter: ssitter, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
'All' vs. 'This occurrence' dialog not shown when deleting recurring event via menu/toolbar

Sunbird does not show 'All occurrences' vs. 'This occurrence' dialog when deleting recurring event via toolbar, menu or context menu. 

Steps to Reproduce:
1. Create recurring event, e.g. repeat daily from Monday to Friday
2. Select one of the events and select delete command from toolbar,
   menu or context menu

Actual Results:
No 'All occurrences' vs. 'This occurrence' dialog is shown. 
The selected event is deleted immediately (an exception is added).

Expected Results
'All occurrences' vs. 'This occurrence' dialog is shown asking for user decision.

Tested with multiweek and month view.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060329 Mozilla Sunbird/0.3a1+
(Reporter)

Comment 1

12 years ago
Same with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060330 Mozilla Sunbird/0.3a1+
OS: Windows 2000 → All

Comment 2

12 years ago
The tricky bit here is that in theory, people can be deleting tons of events, and we don't want to force them to answer the prompt for each.  Also, note that the current prompt doesn't include any reference to the actual event.  We need to decide how we want that to happen.
http://lxr.mozilla.org/mozilla/source/calendar/resources/content/calendar.js#386
*** Bug 333715 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

12 years ago
*** Bug 334329 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
Blocking 0.5?
Flags: blocking-calendar0.5?

Comment 6

12 years ago
(In reply to comment #2)
> The tricky bit here is that in theory, people can be deleting tons of events,
> and we don't want to force them to answer the prompt for each.  Also, note that
> the current prompt doesn't include any reference to the actual event.  We need
> to decide how we want that to happen.
> http://lxr.mozilla.org/mozilla/source/calendar/resources/content/calendar.js#386
> 
Well, the code knows how many events are currently selected. Why not prompt when there's only one selected?
This would likely require ui changes and we're at string freeze.  Minusing blocking-calendar0.5
Flags: blocking-calendar0.5? → blocking-calendar0.5-

Updated

11 years ago
Flags: blocking-calendar0.7?
(Reporter)

Comment 8

11 years ago
Retest using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.5pre) Gecko/20070702 Calendar/0.7pre:

If one repeating event is selected in view the 'All' vs. 'This occurrence' dialog when deleting using keyboard, toolbar button, menu and context menu.

If more than one event is selected deleting using keyboard, toolbar button and menu just deletes the events or adds exceptions to the repeating events respectively without showing the dialog.

In my opinion this can be resolved worksforme. Thoughts?
Whiteboard: [qa discussion needed]

Comment 9

11 years ago
I would agree that this should be WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: [qa discussion needed]
Flags: blocking-calendar0.7?

Updated

11 years ago
Status: RESOLVED → VERIFIED
Flags: blocking-calendar0.5-
You need to log in before you can comment on or make changes to this bug.