Wrong renaming of double downloaded files

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
RESOLVED WORKSFORME
12 years ago
a year ago

People

(Reporter: giorgos, Unassigned)

Tracking

Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Hi,
I downloaded a file with firefox named "test.tar.bz2". I directly open it with archive manager, do something and close archive manager. Firefox stores "test.tar.bz2" in /tmp . If I download again the same file, firefox renames it to "test.tar-1.bz2" which causes the archive manager to not recognize the "tar" archive type.

Reproducible: Always

Steps to Reproduce:
1. Download test.tar.bz2. Select direct open with archive manager
2. Do something and close archive manager
3. Download the same file again
4. There should be /tmp/test.tar.bz2 and /tmp/test.tar-1.bz2

Comment 1

12 years ago
This should have been handled by the fix to bug 231048, see https://bugzilla.mozilla.org/attachment.cgi?id=184636&action=diff

It WFM on WinXP at least, I get test.tar.bz2 and test(2).tar.bz2.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060331 Firefox/1.6a1 ID:2006033104
(Reporter)

Comment 2

12 years ago
I also get test.tar.gz and test(2).tar.gz if I choose to save the file to disk. If I directly open the file with an application I still get test.tar.gz and test.tar-1.gz
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060407 Firefox/3.0a1 - Build ID: 0000000000
Confirming. Even with the patch to bug #231048 applied, this still happens.
Duping this to bug #231048, and bringing this up over there.

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Component: Download Manager → File Handling
Product: Firefox → Core
Resolution: DUPLICATE → ---
Version: unspecified → Trunk
ExecuteDesiredAction uses CreateUnique, which doesn't really handle those cases very well.
Assignee: nobody → file-handling
OS: Linux → All
QA Contact: download.manager → ian
Hardware: PC → All
This might be a dupe, but I couldn't find it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

11 years ago
Flags: blocking1.9a2?
Flags: blocking1.9a2? → blocking1.9-
Assignee: file-handling → nobody
QA Contact: ian → file-handling
(Reporter)

Comment 6

5 years ago
Well, this is fixed now ;)

Thanks!
Status: NEW → RESOLVED
Last Resolved: 12 years ago5 years ago
Resolution: --- → FIXED

Comment 7

3 years ago
It should be to WFM, if no a landed link.
https://developer.mozilla.org/en-US/docs/What_to_do_and_what_not_to_do_in_Bugzilla#Resolving_bugs_as_WORKSFORME
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.