read-only files in profile directory are overwritten (such as bookmarks, passwords)

RESOLVED DUPLICATE of bug 257288

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 257288
13 years ago
13 years ago

People

(Reporter: Bugzilla, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

I want Mozilla not to overwrite my passwords file (*.s) - I have my reasons for that. With Mozilla 1.7.12 you could just set a file's (the *.s file or bookmarks.html for example) read-only attribute to prevent Mozilla from overwriting it. This does not work with SeaMonkey anymore.

Reproducible: Always

Steps to Reproduce:
1. set the read-only attribute for bookmarks.html
2. add a bookmark in SeaMonkey
Actual Results:  
SeaMonkey renames the original file to bookmarks.html.moztemp and creates a new bookmarks.html.
Same behaviour for the *.s file which stores one's passwords.

Expected Results:  
If SeaMonkey cannot write to a file, show the user a warning message with "Retry", "Ignore" and "Ignore and don't show this warning again" options.
(Reporter)

Updated

13 years ago
Summary: read-only readonly files in profile directory are overwritten (such as bookmarks, passwords) → read-only files in profile directory are overwritten (such as bookmarks, passwords)
Version: unspecified → 1.8 Branch

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 257288 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.