bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Holding down ctrl should display access key for tabs 1-9

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED WONTFIX
12 years ago
12 years ago

People

(Reporter: Ian Macfarlane, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.00 (Windows NT 5.0; U; en)
Build Identifier: 

Firefox 1.5 introduced pressing ctrl+(1-9) to select tabs 1-9. Displaying the access key would make easier to determine which number you should press to select that tab.

E.g. For tab number 8 for example, it's probably more work to count up to that tab to work out that it is number 8 than to select it some other way.

A visual cue would also improve the discoverability of this feature.

Suggestions:
 - replace the favicon with stylised icons numbered 1-9
 - replace the title instead, and keep displaying the favicons
 - display it some other way, e.g. a small tab below each tab.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

12 years ago
Blocks: 308396, 318168
No longer blocks: 308396, 318168
If this were the primary, or even the secondary, means of switching tabs, I might think about this.  But its a neat little feature that's pretty poweruserish, and holding Ctrl is more likely to be a lot of other unrelated shortcuts, so changing UI just seems kinda silly.  Would be an interesting extension I'm sure.

Not to mention we don't currently track ctrl in the event model per the DOM events spec, since its a modifier, not an action key, so we can't detect the keydown (which is why bidi locales can't use the right/left ctrl-shift to switch text directions in textfields).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.