gu-IN build has font issues on Mac

RESOLVED DUPLICATE of bug 205476

Status

Core Graveyard
GFX: Mac
RESOLVED DUPLICATE of bug 205476
12 years ago
10 years ago

People

(Reporter: marcia, Assigned: smontagu)

Tracking

1.8 Branch
PowerPC
Mac OS X
Bug Flags:
blocking1.8.1 -
blocking1.8.0.4 -

Firefox Tracking Flags

(Not tracked)

Details

Seen testing Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; gu-IN; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2.

On the Mac, I have the font set installed but the build only shows fonts in the top level menu. Everywhere else in the UI shows question marks (RSS feed labels, other menu items like customize the toolbar)

Tracy reports that Windows is fine - the problem seems to be confined to Mac, and Linux but I am not sure that Linux gracefully handles that font.

Comment 1

12 years ago
Ankit, could you detail on how to set up fonts for gu-IN on Mac and Linux?

Comment 2

12 years ago
I use Linux (Red Hat Enterprise Linux 4).

As far as i know the fonts should be unicode fonts to get your firefox into gujarati. So, if you have got the correct(unicode) fonts then please follow the following link to install the fonts.
http://www.indianoss.org/modules/xoopsfaq/index.php?cat_id=1#q6

The fonts which i use are lohit fonts. Here is the link for that font. You can use that one too.
RPM :-
http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/Fedora/RPMS/fonts-gujarati-1.10-2.1.noarch.rpm
Font :-
http://prdownloads.sourceforge.net/indianoss/lohit_gu.ttf?download

Please tell me if you have any problem...
marcia, did you get a chance to retest Linux after doing:

# yum install fonts-gujarati

?

Comment 4

12 years ago
If this locale was skipped for 1.5.0.2 because of this font issue, I would suggest we figure out what users need to do in order to get the fonts working and try to get this out for 1.5.0.3.  

Although I can't read Gujarati, I do speak it, so just looking out for my peeps. :-)

Ankit:  If you want to see gu-IN for the next release, please help us figure out how to make the user experience on all platforms better.  I'm guessing most gu-IN users will be on Windows, and you have provided some helpful info for Linux, but we need to get Mac working too. 

If QA can verify builds on all three platforms next time with some help with the fonts, we can look into getting this ready for 1.5.0.3.
Flags: blocking1.8.0.3?
The Linux one works for me on my FC5 machine, on which I have fonts-gujarati-1.10-2.1 (and some other fonts that might have the characters) installed.
Summary: gu-IN build has font issues on Mac and Linux → gu-IN build has font issues on Mac

Comment 6

12 years ago
On Linux and Mac OS X, Gujarati won't be rendered correctly (although it may still be legible) because in 1.5.x, we don't use complex script rendering APIs (pango on Linux and ATSUI on OS X : see bug 215219 and bug 121540). On Windows, we don't either (uniscribe in that case), but the default text-drawing/measuring APIs work more or less (unless text is justified) work there. On Linux, if you build with '--enable-pango', it should work (bug 214715), but it would slow down the rendering of non-complex script pages significantly. As mentioned in comment #2, installing truetype fonts for Gujarati (with the correct encoding table) on Linux makes Gujarati 'usable', but on Mac OS X, the situation is worse (fonts may not even be selectable or even if selected, it won't work correctly)

Nonetheless, if we already have localized builds for other Indic scripts, there's little reason to block gu-IN because other Indic scripts have exactly the same problem.

Comment 7

12 years ago
(In reply to comment #4)
> If this locale was skipped for 1.5.0.2 because of this font issue, I would
> suggest we figure out what users need to do in order to get the fonts working
> and try to get this out for 1.5.0.3.  
> 
> Although I can't read Gujarati, I do speak it, so just looking out for my
> peeps. :-)
> 
> Ankit:  If you want to see gu-IN for the next release, please help us figure
> out how to make the user experience on all platforms better.  I'm guessing most
> gu-IN users will be on Windows, and you have provided some helpful info for
> Linux, but we need to get Mac working too. 
For Linux it's working fine. For Windowx XP and 2000 there is no problem with gujarati firefox. You can check it. For Mac i am helpless...

> 
> If QA can verify builds on all three platforms next time with some help with
> the fonts, we can look into getting this ready for 1.5.0.3.
> 

Yeah, the problem on Mac looked like an i18n bug, not a localization problem.  My guess would be that we don't understand the encoding of the Gujarati fonts on Mac OS X, so we can't display Gujarati text at all, even if the fonts are installed.  My guess would be that that's the same in any localization for a Web page using Gujarati characters.

->Core/Internationalization
Assignee: nobody → smontagu
Component: Other → Internationalization
Product: Mozilla Localizations → Core
QA Contact: amyy
Version: unspecified → 1.8 Branch

Comment 9

12 years ago
(In reply to comment #8)
> Yeah, the problem on Mac looked like an i18n bug, not a localization problem. 
> My guess would be that we don't understand the encoding of the Gujarati fonts

It just has Unicode cmap (nothing fancy). However, even Safari doesn't work properly with Gujarati (or any opentype fonts for any Indic and complex scripts) ttfs with gsub/gxxx tables but *without* AAT tables.


> ->Core/Internationalization

It's Gfx:Mac. 

Component: Internationalization → GFX: Mac
A fix doesn't look likely in the 1.8.0.x timeframe. Not blocking 1.8.0.x though of course we'd love to take one if a patch is available.
Flags: blocking1.8.1+
Flags: blocking1.8.0.3?
Flags: blocking1.8.0.3-

Comment 12

12 years ago
(In reply to comment #11)
> Is this the same as bug 205476?
> 
Yes, bug 205476 looks like superset of this bug.  Bug 205476 also has a patch which looks like would be good to take as soon as possible.  It would be great to get pa-IN and gu-IN working on Mac.

Comment 13

12 years ago
No trunk patch; not going to block FF2 beta1 for this.  We might consider a patch for FF2 beta2.
Flags: blocking1.8.1+ → blocking1.8.1-

Comment 14

12 years ago
Well, bug 121540 has a better patch than bug 205476. 

Comment 15

11 years ago
Any updates on this bug?
This works on trunk now.  This bug is explicitly filed against the 1.8 branch, which won't ever be fixed, so I suppose the correct resolution is WONTFIX (otherwise, dupe it to bug 205476).
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 205476
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.