Allow the Location bar to be implicit/complete the hidden navigation bar layout.

RESOLVED INVALID

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Darkintent, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Opera/8.52 (X11; Linux x86_64; U; en)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060408 Firefox/1.5.0.1

I would appreciate it if it was posible to set the urlbar/box to automatically become active if I begin typing instead of having to first bring the url entry text field into focus.  I already know that I want to go to a given web address before I have even brought the url entry field into focus and it is something I think that the web browser itself should be able to determine without me doing something that is almost entirely redundant like typing alt+D or ctrl+L when there are no other text fields in focus in the webpage or in the browser such as the search bar and the find bar.

I have also noticed that currently it is not possible to to use the alt+enter shortcut to force a url to open in a new tab if one hides the navigation toolbar.  It makes no sense to force the user to use the mouse to select open in a new tab from a drop down box or to have them open the tab first when alt+enter already provides an appropriate way to handle this.  It also does not seem to be possible to set this and other keybindings by default from the GUI.

The status bar should also have the ability to only show itself when a page is loading without the need for an extension like autohide-statusbar.  Leaving the status bar active at all times is not really desireable given that I can view more of a web page without scrolling with the bar hidden most of the time.

I also think that it would be a good idea to have ctrl+c automatically copy a url to the clipboard if no other text is selected; in conjunction with ctrl+v automatically summoning the urlbar with the pasted contents of the clipboard already filled in, or simply filling in the urlbar with the copied text if no other text field is active.  It would also be nice to have a paste and go feature out of the box. I am aware of hacks and extensions that do this but it would still be nice to not need an extension or hack for something like that.

Reproducible: Always
Please in the future read the bug writing guidelines and keep to a single issue for a single bug rather than posting 4 seperate issues to the same one.

The first and last issues you talk about would make things extremely confusing, it would be difficult to say which action would happen, maybe a page has an input field or selection that I cant see.

I would say that the least useful feature of the status bar is that it shows you progress of page loading. A recent discussion on the newsgroup about potentially hiding the status bar by default in firefox 2 came out as a resounding no since people would then not be able to see where links would take them, so I cant see what you suggest happing as default.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Please in the future read the bug writing guidelines and keep to a single issue
> for a single bug rather than posting 4 seperate issues to the same one.
> 
> The first and last issues you talk about would make things extremely confusing,
> it would be difficult to say which action would happen, maybe a page has an
> input field or selection that I cant see.
> 
> I would say that the least useful feature of the status bar is that it shows
> you progress of page loading. A recent discussion on the newsgroup about
> potentially hiding the status bar by default in firefox 2 came out as a
> resounding no since people would then not be able to see where links would take
> them, so I cant see what you suggest happing as default.
> 

The whole point is that the option would only actually work if no other text field has focus and there really is no reason for a website text field to automatically have focus as soon as the website has loaded.  If it does do that the site is either badly designed or there is a bug in the browser itself.  The first and last issue both require that no other text field be active at all the alternative is to focus the urlbar then copy the text and then paste the text somewhere.
This becomes very tedious if you hide the navigation bar since you would have to summon the box then banish it using escape for example so that you could move to the next tab and paste the url.  Something I do fairly often, it begs the question why the hidden mode of the navigation bar has been so greatly overlooked in the first place.  

The statusbar being having the option of being hidden unless a page is loading [for example] is not confusing at all because the statusbar would become active when appropriate another possible option is to have it appear when you hover over a link.

The things I point out all more or less lend themselves to discussion when one is talking about how to make hidden navbar navigation more useful.  Right now hiding the navigation bar makes Firefox crippled as it is with no easy way to copy/paste (and go) a url without otherwise focusing the urlbar which turns into  a minimum two step process if you decide to hide the navigation toolbar.  Using an implicit urlbar also makes it easier to "focus" the urlbar in the event that you decide to hide the navigation bar since hiding the navigation bar disallows the use of the mouse to bring the text entry field into focus, and simply typing a url [or even a keyword] is easier than in some cases reaching across the keyboard to use a shortcut to bring the urlbar into focus.
I should probably have done this earlier, but I would suggest that this bug be closed, it's scope is somewhat too large and I can forsee it becoming a useful discussion. Instead I would suggest that you start a thread on the mozilla newsgroups, the group mozilla.dev.apps.firefox is probably best (available on googlel groups at http://groups.google.com/group/mozilla.dev.apps.firefox). It will probably get a wider input there as well.
One issue per bug, please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.