If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

hitting "back" after accessing a "save as" file and another page triggers "save as" event again.

VERIFIED DUPLICATE of bug 23734

Status

()

Core
Networking: Cache
P3
normal
VERIFIED DUPLICATE of bug 23734
18 years ago
18 years ago

People

(Reporter: mrmcd, Assigned: gordon)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Using win32 build #2000032308
to reproduce:
1.) goto URL logged. (http://www.thesync.com/geeks)
2.) click "play now with streaming MP3". "Save/Pick/More info" dialog should pop up.
3.) Click "more info".
4.) Click "back".
result: "save/pick/more info" dialog box reappears.
expected: should return to original URL. Bowser appears to be following a
litteral URL access historical path, instead of a page load historical path.
Possible this is intentional, but probably not, and is highly annoying.
also recreatable:
at "save/pick/info" dialog
1.) Click cancel
2.) navigate to any other page
3.) click "back".
result: "save/pick/more info"  dialog box appears.

Comment 1

18 years ago
The 1st part of the report is a duplicate of bug #23734 "downloading files
should not be added to history".

The second part is a duplicate of bug #29975 "cancelling on save as.. puts
the link in history".

*** This bug has been marked as a duplicate of 23734 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
good call 
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.