Last Comment Bug 333638 - label with ref that uses relative xpath doesn't work in repeat
: label with ref that uses relative xpath doesn't work in repeat
Status: RESOLVED WONTFIX
:
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: xforms
: Stephen Pride
:
Mentors:
http://marimba.murkworks.com/bkc/xfor...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 15:09 PDT by Brad Clements
Modified: 2016-07-15 14:46 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Demonstrates relative ref problem in repeat (3.83 KB, application/xhtml+xml)
2006-04-11 15:09 PDT, Brad Clements
no flags Details
simpler testcase (1.03 KB, application/xhtml+xml)
2006-04-11 15:16 PDT, aaronr
no flags Details
Testcase (1.62 KB, application/xhtml+xml)
2006-04-12 01:35 PDT, Allan Beaufour
no flags Details

Description Brad Clements 2006-04-11 15:09:04 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060410 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060410 Firefox/1.5.0.2

In 0.5RC

Given an input element whose label uses a relative xpath, like

<xf:input ref="@selected">
 <xf:label ref="../@ordernumber" />
</xf:input>

This works outside of a repeat but fails in the repeat.


Reproducible: Always

Steps to Reproduce:
1. Load the test sample

Actual Results:  
No value is retrieved for the label

Expected Results:  
Label should have the correct value like it does outside of repeat.

Also the attached example shows another refresh issue in repeat.

The use of index() in a labels ref in the repeat causes strange behavoir and
page lockup. I realize that this use doesn't make sense and is incorrect,
but shouldn't cause layout issues.
Comment 1 Brad Clements 2006-04-11 15:09:33 PDT
Created attachment 218093 [details]
Demonstrates relative ref problem in repeat
Comment 2 aaronr 2006-04-11 15:16:35 PDT
Created attachment 218095 [details]
simpler testcase
Comment 3 aaronr 2006-04-11 15:24:54 PDT
problem seems to be with the context node that label is getting when trying to bind.  In my simplified testcase, the context node coming back for the label is the <item>, not the @value of the <item>.
Comment 4 Allan Beaufour 2006-04-12 01:35:14 PDT
Created attachment 218151 [details]
Testcase

Yet another testcase. It seems like the problem is more refined, it's only when you use attributes that it fails. And Aaron is right, it uses the node, and not the attribute as the context node.
Comment 5 aaronr 2007-02-22 17:17:42 PST
as far as I can tell, the label issue is gone in 0.7.  The refresh issue Brad noticed still exists, though.
Comment 6 alexander :surkov 2007-02-22 21:16:09 PST
(In reply to comment #5)
> The refresh issue Brad
> noticed still exists, though.
> 

Can it be related with bug 362308?
Comment 7 David Bolter [:davidb] 2016-02-04 12:21:49 PST
RIP xforms

Note You need to log in before you can comment on or make changes to this bug.