anchored links in DIVs fail with position: absolute

VERIFIED DUPLICATE of bug 35772

Status

()

P2
major
VERIFIED DUPLICATE of bug 35772
19 years ago
10 years ago

People

(Reporter: jimclow, Assigned: buster)

Tracking

({css2})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
First seen in M14 at http://members.cts.com/crash/j/jimclow/ which is the basis 
for the test URL given. The problem also exists in M15 build 2000032416.

The test URL eliminates an initial page and JavaScript used to open a new window 
based on client's screen resolution. The test URL also eliminates FORM and 
SELECT material replacing it with anchored links. The number of subordinate 
links was reduced to six in the test.

The original and test URLs work as intended in all NC versions tested (4.04, 
4.72) and IE5.0

Brief description:
Eight DIVs are used to position an image, links, text and a form. The first DIV 
displays a 'background' image. The second - fourth DIVs provide anchored links 
to two pages each. The fifth - seventh DIVs provide text to categorize the three 
sets of links. The eigth DIV provides an Exit button. All eight DIVs use 
STYLE="Position:absolute;...

Problems:

1. Only the uppermost link "P10: ..." is hot, and only the upper limit of the 
link text is hot. The position of the three DIVs with links match those in NC 
and IE.

2. The position of the three text DIVs does not match that in NC and IE. 

The Exit button is positioned the same as in NC and IE, and it works.

Comment 1

19 years ago
What is the status on this one, been a long time and confirmed here. THANKS

Comment 2

19 years ago
I trust Jay enough to mark it verified.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

19 years ago
Buster, this is really the same issue as 28526. The problem here is that we're 
getting extra white space in some of the absolutely positioned elements.

The reason is that the rules in html.css that suppress the margin-top for the 
first child in a BODY and TD don't apply here, but we really want them to. So 
we're ending up with extra vertical whitespace

Assignee: troy → buster
(Assignee)

Updated

19 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: --- → M17
Nom. nsbeta3. links are failing to work (html32 functionality!). Renders css2 
positioning unusable to position elements as desired in this case because so 
doing breaks basic html page usability. Recc. nsbeta3+.
Keywords: 4xp, css2, nsbeta3
(Assignee)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 35772 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Keywords: verifyme

Comment 6

18 years ago
vrfy
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.